mar1030
?>

Создать игру в программе Скретч Кот бегает за мышкой 1) кот бегает за мышю2) кот бегает с клавиатуры, мышка позвольно3) если кот поймает мышку, то её съедает (мышка исчезает игра заканчивается)​

Информатика

Ответы

Vik1744184
#include <iostream>
using namespace std;

int main() {
 setlocale(LC_ALL, "Russian");
 int n,k;
 string s[3][3]=
 {{"1 - Перу","2 - Тайланд","3 - Венгрия"},
 {"Лима, Арекипа, Куско", "Паттайя, Чиангмай, Сиемреап", "Сентендре, Секешфехервар, Веспрем"},
 {"Все эти замечательные города находятся в Перу",
 "Паттайя и Чиангмай находятся в Тайланде, но Сиемреап - это Камбоджа",
 "Все перечисленные города с непростыми названиями находятся в Венгрии"}};
 cout << "Выбери страну по номеру: " << s[0][0] << " " << s[0][1] << " " << s[0][2] << "\n";
 cin >> n;
 cout << "Относятся ли перечисленные ниже города к выбранной стране?\n";
 cout << s[1][n-1] << "\n";
 cout << "Да-1, Нет-0 ";
 cin >> k;
 if ((n==1)&&(k==1)||(n==2)&&(k==0)||(n==3)&&(k==1)) cout << "Вы правы! \n";
 else cout << "Вы ошиблись.\n";
 cout << s[2][n-1];
 return 0;
}

Написать программу, которая показывает пользователю на экран три страны и предлагает выбрать одну. п
milo4ka26
Var a:array[1..100,1..100] of integer; i,j,n,m,max,min:integer; begin write ('Введите количество строк: '); read(n); writeln; write ('Введите количество элементов в строке: '); read(m); writeln; writeln('Введите массив: '); for i:=1 to n do begin for j:=1 to m do begin write(' a[',i,',',j,']='); read(a[i,j]); end; writeln; end; writeln; writeln('Исходный массив: '); for i:=1 to n do begin for j:=1 to m do write(a[i,j],' '); writeln; end; writeln; writeln('Конечный массив: '); for i:=1 to n do begin min:=a[i,1]; max:=a[i,1]; for j:=2 to m do begin if (min>a[i,j]) then min:=a[i,j]; if (max

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Создать игру в программе Скретч Кот бегает за мышкой 1) кот бегает за мышю2) кот бегает с клавиатуры, мышка позвольно3) если кот поймает мышку, то её съедает (мышка исчезает игра заканчивается)​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yevsyukov1697
zubov-073620
symkifm
shilinmikhaillg
russstep
Viktorovich395
Ohokio198336
Bobkov
mishink535
Manyaya
Lukina
ivanjeka87
Валентинович133
Vkois56
daryagulyaeva