zabrodin
?>

Опишите модель решения поставленной задачи, соблюдая следующие пункты:а) Входные данные программыб) Выходные данные программыв) Цель проектирования программыг) Назначение программыд) Область применения программы​

Информатика

Ответы

osnovnoisklad3551

program n_1;

var a: array [1..30] of integer; n, m, k, l, i:integer; s: double;

begin

 n:=0; m:=0; n:=0; k:=0; l:=0;

 for i:=1 to 30 do begin

   read(a[i]);

   s:=s+a[i];

   if a[i]=2 then m:=m+1

   else if a[i]=3 then n:=n+1

   else if a[i]=4 then k:=k+1

   else if a[i]=5 then l:=l+1

 end;

 writeln('Средний класса: ', s/30);

 writeln('Количество двоечников: ', m);

 writeln('Количество троечников: ', n);

 writeln('Количество хорошистов: ', k);

 writeln('Количество отличников: ', l);

 writeln('Успеваемость класса: ', (30-m)/3*10, '%');

end.

dima0218687

Не совсем понимаю, как здесь использовать двоичную матрицу, поэтому решу по-своему.


Шестикласснику не повезло — он не нашёл ни одного гриба, а Петя с пятиклассником нашли много грибов.

Вывод 1: Петя или 7-классник, или 8-классник.


Ваня и семиклассник нашли куст малины и позвали Кирилла полакомиться ягодами.

Вывод 2: Ваня и Кирилл не семиклассники.


Восьмиклассник, шестиклассник и Кирилл объясняли Саше, как ориентироваться на местности.

Вывод 3: Кирилл и Саша или в 5 классе, или в 7 классе.

Вывод 4: Так как 5 и 7 класс - это Кирилл и Саша, пока неизвестно в каком порядке, значит, что Петя не может быть 7-классником. Следовательно, он 8-классник.

Вывод 5: Исходя из вывода 2 и 4, Ваня и Кирилл занимают 5 и 6 класс.

Объединим выводы 3 и 5 - Кирилл в 5 классе, Саша в 7 классе, Ваня в 6 классе.


ответ: 5 класс - Кирилл, 6 класс - Ваня, 7 класс - Саша, 8 класс - Петя.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Опишите модель решения поставленной задачи, соблюдая следующие пункты:а) Входные данные программыб) Выходные данные программыв) Цель проектирования программыг) Назначение программыд) Область применения программы​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Вадимовна
Shevtsov1818
Sergei1805
Сурат1199
ПетровичЖивотовская1245
dkvsadovoe
kokukhin
mishamedbrat
merzlikinairena
yurievaalxndra55
ganzashop
puchkovajulia
ekasatkina
Ofelya1308
razumeiko0790