saljagindima
?>

Очень Пользователь вводит с клавиатуры целые положительные числа, разделяемые нажа-тием клавиши . Признаком конца последовательности является число 0.Напишите программу, которая выводит на экран:a) сумму и среднее арифметическое четных чисел;b) сумму и среднее арифметическое нечетных чисел.2)Напишите программу, которая переводит десятичные числа 1, 5, 10, 50, 100, 500 и 1000, считываемые с клавиатуры, в римские.3) Вычислите сумму первых n элементов:Указание. Используйте внутри цикла оператор if odd(...) then ... else ...

Информатика

Ответы

Amulenkov
Задача №1
var a:array[1..4, 1..5] of integer; 
i,j,k:integer; 
begin 
writeln('Заполните матрицу'); 
for i:=1 to 4 do 
for j:=1 to 5 do begin 
read(a[i,j]); 
if (a[i,j] mod 3=0) and (a[i,j]>20) then k:=k+a[i,j]; 
end; 
writeln('Сумма элементов кратных 3-м и > 20 = ',k); 
end.

Задача №2
var a:array[1..5, 1..5] of integer; 
i,j,k:integer; 
begin 
writeln('Заполните матрицу'); 
for i:=1 to 5 do 
for j:=1 to 5 do begin 
read(a[i,j]); 
if i=j then k:=k+a[i,j]; 
end; 
writeln('Сумма элементов главной диагонали = ',k); 
end.
mouse-0211fsb3509

1. Окончание срока действия триальной версии (следует приобрести лицензионную копию продукта, а если она была приобретена - переактивировать, обратившись за в техподдержку (адреса и телефоны см. в мини-форуме во Эта надпись появляется тогда, когда вы открываете документы, созданные в более ранних версиях редактора, например, в Word 2003. В этом случае не используются новые возможности редактора, обеспечивая режим совместимости разных версий.

Нужно преобразовать документ в формат Office 2007. Тогда эта надпись исчезнет, но при открытии преобразованного документа в более ранних версиях редактора возникнут проблемы при редактировании, либо уже при открытии документа.

Чтобы преобразовать документ, щелкните по кнопке Office и выберите команду Преобразовать. Откроется диалоговое окно, предупреж дающее о последствиях такого преобразования. Если вы подтвердите преобразование, то заменит / сохранит текущий документ в новом формате.

Если кнопка "Преобразовать отсутствует" - следует сохранить две версии одного документа: одна для старых редакторов, другая в новом формате. Это делается стандартно через выбор команды Сохранить как... .

3. Возможно, сработала защита документа (Вкладка - "Рецензирование" - "Защитить документ" - "Отключить защиту").

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Очень Пользователь вводит с клавиатуры целые положительные числа, разделяемые нажа-тием клавиши . Признаком конца последовательности является число 0.Напишите программу, которая выводит на экран:a) сумму и среднее арифметическое четных чисел;b) сумму и среднее арифметическое нечетных чисел.2)Напишите программу, которая переводит десятичные числа 1, 5, 10, 50, 100, 500 и 1000, считываемые с клавиатуры, в римские.3) Вычислите сумму первых n элементов:Указание. Используйте внутри цикла оператор if odd(...) then ... else ...
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

magnit-expo
iivanov54
Nertman45
Svatela37
rezh2009766
BelozerovaGeller648
andreykrutenko
fokolimp
boro-1973
VASILEVNA
aleksandramir90
Mexx9050
ocik1632933
preida-2
mtcover