aedunova3
?>

На вход программе подается натуральное число n, затем n строк, затем число k — количество поисковых за затем k строк — поисковые за Напишите программу, которая выводит все введенные строки, в которых встречаются все поисковые за Формат входных данных На вход программе подаются натуральное число n — количество строк, затем сами строки в указанном количестве, затем число k, затем сами поисковые за Формат выходных данных Программа должна вывести все введенные строки, в которых встречаются все поисковые за Примечание. Поиск не должен быть чувствителен к регистру символов. Пример входных данных: 5 Membrane-potential dynamics mediate bacterial electrical signaling at both intra- and intercellular levels. This equation, derived from the electromagnetic theory (24), expresses that the maximum change in the membrane potential of a cell caused by an electrical stimulus is proportional to the applied field strength. In this study, we utilized an exogenous electrical stimulus to in- vestigate the impact of proliferative capacity on electrical signal response. To investigate the potential impacts of proliferative capacity on electrical signaling responses, direct observation of cell proliferation, membrane potential, and its response to electrical stimuli at the individual-cell level is needed. To test this hypothesis, the same experiment was conducted with a mutant strain lacking the gene encoding the YugO potassium channel. 2 membrane potential Вывод программы: Membrane-potential dynamics mediate bacterial electrical signaling at both intra- and intercellular levels. This equation, derived from the electromagnetic theory (24), expresses that the maximum change in the membrane potential of a cell caused by an electrical stimulus is proportional to the applied field strength.

Информатика

Ответы

mikchaylovaalex
Program Task;
Const N = 5;
Var a: Array [1..N] of LongInt;
    i: Integer;
Function MinDigit(number: LongInt): Integer;
Var digits: Array of Integer;
    num, min, i: Integer;
Begin
    num := number;
While num <> 0 Do
Begin
    num := num Div 10;
    i := i + 1;
End;
    SetLength(digits, i);
    num := number;
For i := 0 To Length(digits) - 1 Do
Begin
    digits[i] := num Mod 10;
    num := num Div 10;End;
For i := 0 To Length(digits) - 1 Do
    If digits[i] < digits[min] Then
    min := i;    Result := digits[min];
End;
Begin
    WriteLn('Введите ', N, ' целых чисел через пробел');
    For i := 1 To N Do
        Read(a[i]);
    For i := 1 To N Do
        Write(MinDigit(a[i]), ' ');
End.
chuev4444
Type
    bignum = array[1..100] of integer;

var
    a, b: bignum;
    i, j, k, n_a, n_b: integer;

procedure get_num(var m: bignum; var n: integer);
var
    i := 0;
    s: string;
begin
    write('Введите число = ');
    readln(s);
    s := trim(s);
    n := 0;
    for i := length(s) downto 1 do
        if s[i] in ['0'..'9'] then begin
            n := n + 1;
            m[n] := strtoint(s[i]);
        end;
end;

function more(a, b: bignum; n_a: integer): boolean;
var
    i: integer;
    f := false;
begin
    for i := n_a downto 1 do
    begin
        if a[i] > b[i] then f := true
        else if a[i] < b[i] then f := false;
        if a[i] <> b[i] then break;
    end;
    more := f;
end;

procedure show(m: bignum; n: integer);
var
    i: integer;
begin
    write('Вывод ');
    for i := n downto 1 do
        write(m[i]);
    writeln();
end;

begin
    get_num(a, n_a);
    get_num(b, n_b);
   
    while (n_a >= n_b) and more(a, b, n_a) do    
    begin
        if (a[n_a] > b[n_b]) then k := n_a - n_b
        else if n_a > n_b then k := n_a - n_b - 1
        else k := 0;
       
        for i := 1 to n_b do
        begin
            a[i + k] := a[i + k] - b[i];
            if a[i + k] < 0 then begin
                for j := i + k to n_a - 1 do
                begin
                    if a[j] >= 0 then break;
                    a[j] := a[j] + 10;
                    a[j + 1] := a[j + 1] - 1;
                end
            end;
        end;
        if a[n_a] = 0 then n_a := n_a - 1;
    end;
   
    show(a, n_a);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На вход программе подается натуральное число n, затем n строк, затем число k — количество поисковых за затем k строк — поисковые за Напишите программу, которая выводит все введенные строки, в которых встречаются все поисковые за Формат входных данных На вход программе подаются натуральное число n — количество строк, затем сами строки в указанном количестве, затем число k, затем сами поисковые за Формат выходных данных Программа должна вывести все введенные строки, в которых встречаются все поисковые за Примечание. Поиск не должен быть чувствителен к регистру символов. Пример входных данных: 5 Membrane-potential dynamics mediate bacterial electrical signaling at both intra- and intercellular levels. This equation, derived from the electromagnetic theory (24), expresses that the maximum change in the membrane potential of a cell caused by an electrical stimulus is proportional to the applied field strength. In this study, we utilized an exogenous electrical stimulus to in- vestigate the impact of proliferative capacity on electrical signal response. To investigate the potential impacts of proliferative capacity on electrical signaling responses, direct observation of cell proliferation, membrane potential, and its response to electrical stimuli at the individual-cell level is needed. To test this hypothesis, the same experiment was conducted with a mutant strain lacking the gene encoding the YugO potassium channel. 2 membrane potential Вывод программы: Membrane-potential dynamics mediate bacterial electrical signaling at both intra- and intercellular levels. This equation, derived from the electromagnetic theory (24), expresses that the maximum change in the membrane potential of a cell caused by an electrical stimulus is proportional to the applied field strength.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Bella Sergei
Антон
KseniGum9
Gulyaev_Egorkina
marketing601
yusinelnik8
ruslanchikagadzhanov
ank9809
Попов1946
konstantin0112
Paikina Natalya30
Azat859
Aleksandr-Andrei
slastena69678
lanabogd