Екатерина
?>

На PYTHON. Любые буквы. Напишите программу, выводящую из заданной строки:а) все цифры;б) сумму всех цифр;в) сумму цифр либо сообщение, что в строке цифр нет.​

Информатика

Ответы

ver2bit
PascalABC.NET

1)
 const     n = 10;
 var
   a : array [1..n] of integer;
   i : integer;
 begin 
  randomize; 
   for i := 1 to n do 
    begin 
    a[i] := 22 + random(114); 
    if a[i] > 100 then 
     writeln (a[i]); 
    end;
  end.

2)
 var 
  a,n,r,i : integer; 
   begin 
 r := 1; 
 readln (a,n); 
  for i := 1 to n do 
   r := r * a;
  writeln (r);
   end.

3)

 var 
 n,i,r : integer;
    begin 
 r := 1; 
 readln (n);
   for i := 1 to n do
    r := r *i; 
 writeln (r);
  end.

4)
 var 
 i : integer;
 begin
  for i := 192 to 223 do
   write(chr(i); ,'  '); 
end.

5)
 var 
 i : integer; 
   begin  
  for i := 255 downto 240 do
   write (chr(i),' ');  
  writeln();  
  for i := 239 downto 224 do 
 write (chr(i),' ');  
  end.

7)
 var 
 i : integer; 
begin  for i := 122 downto 97
do   writeln(chr(i)); 
end.
novkatrina

1)

Var

a:array[1..10] of integer;

i:integer; 

begin

for i:=1 to 10 do

read(a[i]);

randomize;

for i:=1 to 10 do

a[i]:=random(136)+22;

for i:=1 to 10 do

if a[i]>100 then writeln(a[i]);

end.

2.

var

a,n:integer;

begin

readln(a,n);

a:=a^n;

writeln(a);

end;

6.

var

x:array[1..5] of real;

i:integer;

begin

for i:=1 to 5 do

begin

 

read(x[i]);

 

if x[i]=9 then x[i]:=x[i]*3;

if x[i]>9 then x[i]:=x[i]/10;

 

writeln(x[i]); 

end; 

 end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На PYTHON. Любые буквы. Напишите программу, выводящую из заданной строки:а) все цифры;б) сумму всех цифр;в) сумму цифр либо сообщение, что в строке цифр нет.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

elenachuxina804
pannotolstova488
evainvest1
Andreevna_Grebenshchikova155
a8227775
MikhailNechaeva
kadrevproduction
lera4075
shugayzhanna6
scorpion21c
Smolkovaya
Анатольевич1707
Vasilevna_Mikhail19
Надья-Олеговна
Tatyana1374