Написать программу с использованием цикла FOR на языке Python: вывести на экран квадраты и кубы всех натуральных чисел от A до B. Числа A, B задает пользователь ПОМАГИТЕ
Первый условно назовем "я - компьютер". Вы превращаетесь в Исполнителя и с железной тупостью выполняете алгоритм - инструкцию за инструкцией, каждый раз выписывая на бумаге результат. Если у Вас много времени и Вы, как и компьютер, не делаете ошибок, то рано или поздно нужный результат будет получен.
Второй назовем "я - человек". Вы напрягаете свой мозг и определяете, что именно делает алгоритм, после чего проводите нужные вычисления. В этом варианте обычно к результату приходят быстрее.
Попробуем второй путь.
Вначале полагаем, что s=0, n=12. Далее следует цикл, в котором i последовательно принимает значения 1, 2, ... 10. s=s+"что-то" говорит нам о том, что в s накапливается некая сумма, для чего s предварительно обнулялось. А что именно накапливается? n-i. При проходах по циклу это будут значения n-1, n-2, ... n-10. У нас n=12, поэтому в s будет накапливаться сумма 11+10+9+...+2. Или, это удобнее записать как 2+3+4+...+9+10+11. Это сумма арифметической прогрессии из 10 членов и ее можно найти по формуле суммы арифметической прогрессии. Если лениво вспоминать формулу, можно просто сложить эти числа. А можно поступить, как поступил в свое время Гаусс: заметить, что 2+11=13, 3+10=13, 4+9=13 и таких пар 5. И найти результат 5×13=65. Такая вот победа мозга над рутиной))) ответ: 65
marketing
10.01.2021
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64
int main() { std::vector<std::pair<std::string, std::string>> deriv_sheet = { std::make_pair("2x^5", "10x^4"), std::make_pair("cosx", "-sinx") }; std::string user_fx; std::cin >> user_fx; for (const auto& i : deriv_sheet ) if (i.first.compare(user_fx) == 0) std::cout << i.second; }
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу с использованием цикла FOR на языке Python: вывести на экран квадраты и кубы всех натуральных чисел от A до B. Числа A, B задает пользователь ПОМАГИТЕ
Объяснение:
МОЖНО ФОТО Я НЕ ПОНИМАЮ