Kuzina Sergeevna
?>

Напишите программу которая находит минимальный из четных положительных элементов матрицы учтите что таких элементов в матрице может и не бытьc++ двумерные массивы​

Информатика

Ответы

Борисович409
Var
    N, s, i: Integer;
    s1: real;

begin
    readln(N); {общий ввод для всех задач}
    
    if N < 0 then
        writeln('Задача 1. N=', 0)
    else writeln('Задача 1. N=', N + 4);
    
    s := 0;
    for i := 1 to n do
        s := s + i;
    writeln('Задача 7. 1+2+3+…+N=', s);
    
    write('Задача 9. Последовательность от N до 1 = ');
    for i := n downto 1 do
        write(i, ' ');
    writeln();
    
    s1 := 0;
    for i := 1 to n do
        s1 := s1 + i / 10;
    writeln('Задача 12. 0,1+0,2+0,3+..+N/10=', s1);
    
    write('Задача 13. Последовательность квадратов от 1 до N = ');
    for i := 1 to n do
        write(i * i, ' ');
    writeln();
    
    write('Задача 14. Последовательность первых N нечетных чисел = ');
    for i := 1 to n do
        write(2 * i - 1, ' ');
    writeln();
    
    if N > 0 then
        writeln('Задача 20. N степень 3 = ', frac(ln(n) / ln(3)) = 0);
    
    s := 0;
    for i := 1 to n do
        if n mod i = 0 then
            s := s + i;
    writeln('Задача 24. Сумма всех натуральных делителей числа N (сключая 1 и N) = ', s);
end.
goldservicepro
Рекомендуется использовать формулу мальтуса, изменения числа рыб  n= k*n-q*n*n если за начальное количество рыб принять n0,то через год рыб в пруду будет n1=n0+k*n0-q*n0*n0,через два года n2=n1+k*n1-q*n1*n1 в таблице excel в ячейку a1 введите значение к=1,в ячейку b1 значение q=0,01,в ячейку с1 значение n0=100, в ячейку в2 формулу =c1+a1*c1-b1*c1*c1 (это количество рыб за 1 год) , в ячейку в3 формулу =b2+$a$1*b2-$b$1*b2*b2(количество рыб за 2 год) , скопируйте формулу с ячейки в3 до ячейки в11. изменяйте значение ячейки а1, например, поставьте значение 1,908, и получите 2000 рыб через 10 лет.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу которая находит минимальный из четных положительных элементов матрицы учтите что таких элементов в матрице может и не бытьc++ двумерные массивы​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

filternovo
Lazar
Иванович621
evavard
eurostom
lbeglarova6
panstel
dovgash2
atenza3736
Suralevartem
nadnuriewa8110
ksen1280
Yekaterina
Нозадзе_Новиков392
tarasowamash4