kodim4
?>

Задание 6. Определите значение переменной y после выполнения данного блока программы x = 2345; y = x % 10 +x %100/10; * Задание 7. Определите значение переменной f после выполнения данного блока программы x = 459; y =892; f = x / 10 + y % 5; * Задание 8. Определите значение переменной a после выполнения данного блока программы a = 12; if ( a < 15 || a % 5 >0) a = a % 8; else a = a % 7; * Задание 9. Определите значение переменной a после выполнения данного блока программы a=10; b=5; if ( a > 1 && a > b ) a = a-b; if ( a < 1 || a == b ) a = a+b; Задание 10. Какую логическую операцию (&& или ||) нужно добавить в программу вместо многоточия, чтобы значение переменной a после выполнения фрагмента программы стало равно 3? a=10; b=5; if ( a > 1 ... a < b ) a = a-7; else a = a+7; * Задание 11. Напишите программу нахождения положительной разности цифр заданного двузначного числа при условии, что цифры в числе различны. нужны только ответы !

Информатика

Ответы

Dmitrychekov9
Могу в предложить в данном случае использовать goto и метки. Ну, если вы имеете какой то признак неправильных данных, например, это отрицательные значения (предположим, что это неправильные данные) То на этапе, когда вы вводите эти значения, вы должны поставить условный оператор. Т.е.
if a<0 tnen
begin
Writeln('Вы ввели неверные данные');
goto 1
else
goto 2;
Метку 1 вы ставите в начало алгоритма, т.е. туда, откуда вы хотите начать повторное выполнение программы, а метку 2 поставить в продолжение алгоритма, т.е. на тот случай, если данные были введены верно
ooo-helpvet44
Этапы развития компьютерных сетейХотя компьютерная индустрия еще довольно молода по сравнению с другими производствами (например, автомобильной или авиационной промышленностью) , прогресс в сфере производства компьютеров был весьма впечатляющим. В первые два десятилетия своего существования компьютерные системы были сильно централизованными и располагались, как правило, в пределах одного помещения. Часто эта комната оборудовалась стеклянными стенами, сквозь которые посетители могли полюбоваться на великое электронное чудо. Компания среднего размера или университет могли позволить себе один-два компьютера, тогда как у крупных организаций их число могло достигать нескольких десятков. Сама мысль о том, что через какие-нибудь 20 лет столь же мощные компьютеры будут иметь размеры почтовой марки и производиться миллионами, тогда казалась чистой фантастикой.
Объединение компьютеров и средств связи оказало глубокое влияние на принцип организации компьютерных систем. Концепция «компьютерного центра» в виде комнаты, в которой помещался большой компьютер и куда пользователи приносили свои программы, сегодня полностью устарела. Модель, в которой один компьютер выполнял всю необходимую работу по обработке данных, уступила место модели, состоящей из большого количества отдельных, но связанных между собой компьютеров. Такие системы называются компьютерными сетями.
Два компьютера называются связанными между собой, если они могут непосредственно обмениваться информацией. Связь не обязательно должна осуществляться при медного провода. Могут использоваться самые разнообразные средства связи, включая волоконную оптику, радиоволны высокой частоты и спутники связи. Сети могут отличаться друг от друга также размерами и принципами построения. Как ни странно, ни Интернет, ни так называемая Мировая паутина (WWW) не являются собственно компьютерными сетями. Интернет — это сеть сетей, а Веб — распределенная система на базе Интернета.
В литературе существует путаница между понятиями «компьютерная сеть» и «распределенная система» . Основное их различие заключается в том, что в распределенной системе наличие многочисленных автономных компьютеров незаметно для пользователя. С его точки зрения, это единая связанная система. Обычно имеется набор программного обеспечения на определенном уровне (над операционной системой) , которое называется связующим ПО и отвечает за реализацию этой идеи. Хорошо известный пример распределенной системы — это Мировая паутина (World Wide Web), в которой, с точки зрения пользователя, все выглядит как документ (веб-страница) .
В компьютерных сетях нет никакой единой модели, нет и программного обеспечения для ее реализации. Пользователи имеют дело с реальными машинами, и со стороны вычислительной системы не осуществляется никаких попыток связать их воедино. Скажем, если компьютеры имеют разное аппаратное и программное обеспечение, пользователь не сможет этого не заметить. Если он хочет запустить программу на удаленной машине, ему придется явно зарегистрироваться на ней и явно дать задание на запуск.
На самом деле распределенная система является программной системой, построенной на базе сети. Эта программная система обеспечивает высокую степень связности и прозрачности элементов. Таким образом, различие между компьютерной сетью и распределенной системой заключается в программном обеспечении (особенно в операционной системе) , а не в аппаратуре.
Тем не менее эти два понятия имеют много общего. Например, как компьютерная сеть, так и распределенная система занимаются перемещением файлов. Разница заключается в том, кто вызывает эти перемещения — система или пользователь.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задание 6. Определите значение переменной y после выполнения данного блока программы x = 2345; y = x % 10 +x %100/10; * Задание 7. Определите значение переменной f после выполнения данного блока программы x = 459; y =892; f = x / 10 + y % 5; * Задание 8. Определите значение переменной a после выполнения данного блока программы a = 12; if ( a < 15 || a % 5 >0) a = a % 8; else a = a % 7; * Задание 9. Определите значение переменной a после выполнения данного блока программы a=10; b=5; if ( a > 1 && a > b ) a = a-b; if ( a < 1 || a == b ) a = a+b; Задание 10. Какую логическую операцию (&& или ||) нужно добавить в программу вместо многоточия, чтобы значение переменной a после выполнения фрагмента программы стало равно 3? a=10; b=5; if ( a > 1 ... a < b ) a = a-7; else a = a+7; * Задание 11. Напишите программу нахождения положительной разности цифр заданного двузначного числа при условии, что цифры в числе различны. нужны только ответы !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

AHO436
gordeevadesign2986
derkachn6429
zbellatriks
olegmgu1
ganul
nekrasovaolga27
Mexx9050
mmctriitsk
nikitavertiev98400
artem-whitenoise142
Valerii276
Vasilisan
denisovatat7
rusdtver
▲