Strelkov567
?>

Задания по теме «Язык программирования Паскаль. Циклы».Вариант 1 Чему будет равен результат выполнения фрагмента программы?a:= 12;if a div 2 >=6 then b:= a mod 5 else b:= a div 3;write (a–b) . Сколько раз будет выполняться цикл For i:=6 to 10 do… . Сколько раз выполнится цикл: i:=6; while i<6 do i:=i+3 . Чему будет равна переменная sum после выполнения фрагмента программы:sum:=0; for i:=7 to 9 do sum:=sum+i . Сколько раз исполнится следующий цикл: i:=12; Repeat i:=i – 2 Until i>4 . Сколько раз выполнится цикл: i:=4; while i<10 do i:=i+3 . Чему будет равна переменная sum после выполнения фрагмента программы:sum:=0; i:=1; Repeat Sum:=sum+3; i:=i – 1 Until i>11 . Составить программу, выводящую на экран значение вещественной переменной Р, равное значению выражения 〖K*D〗^(2 )/(K+D); K и D – целочисленные переменные, их значения вводятся с клавиатуры. Составить программу, запрашивающую оценки за контрольные работы по информатике и физике. Если их сумма не менее 8, то на экран должен выводится комментарий «Молодец», в противном случае – «Постарайся». Составить программу нахождения суммы квадратов натуральных чисел от 15 до 25.

Информатика

Ответы

vtarasyuk
Сериал повествует о жизни круглых персонажей в стране «Смешариков». У каждого героя свой взгляд на вещи, свои увлечения и яркий характер. Ежедневно герои попадают в неожиданные ситуации или создают их сами.В сериале представлены герои трёх возрастных групп — дети-подростки (Крош, Ёжик, Нюша, Бараш), взрослые (Лосяш, Пин), и пожилые (Кар Карыч, Совунья, Копатыч). Главные герои:

Крош

Ёжик

Нюша

Бараш

Совунья

Кар-Карыч

Пин

Копатыч

Лосяш

Панди

Биби

Ну а если посчитать, всего их 77 (это Группы персонажей

Смешарики: основные персонажи (9)

Смешарики: прочие персонажи (34)

Смешарики: искусственно созданные персонажи (11)

Смешарики: вымышленные персонажи (23))

4.?

uchpapt
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var a:=ReadLines('m17.txt').JoinIntoString.ToIntegers;
  a.Println;
  var b:=a.Select((x,i)->Rec(x,i)).Where(x->x.Item1<0)
    .Select(x->x.Item2).ToArray;
  if b.Count<>2 then
    Writeln('Количество отрицательных элементов не равно двум')
  else begin
    a:=SeqFill(b[0],0).Concat(a.Skip(b[0]).Take(b[1]-b[0]+1))
      .Concat(SeqFill(a.Length-b[1]-1,0)).ToArray;
    a.Println
    end
end.

Тестовое решение:
23 14 7 15 0 13 -6 41 18 13 8 42 27 -11 3 19 10
0 0 0 0 0 0 -6 41 18 13 8 42 27 -11 0 0 0

Файл с исходными данными имеет имя m17.txt. Тестовый файл находится во вложении. Разбивка на строки сделана по 5 значений, но может быть совершенно произвольной. Также нет привязки именно к 17 числам, главное - чтобы отрицательных чисел было ровно два, иначе будет выдано сообщение о их неверном количестве.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задания по теме «Язык программирования Паскаль. Циклы».Вариант 1 Чему будет равен результат выполнения фрагмента программы?a:= 12;if a div 2 >=6 then b:= a mod 5 else b:= a div 3;write (a–b) . Сколько раз будет выполняться цикл For i:=6 to 10 do… . Сколько раз выполнится цикл: i:=6; while i<6 do i:=i+3 . Чему будет равна переменная sum после выполнения фрагмента программы:sum:=0; for i:=7 to 9 do sum:=sum+i . Сколько раз исполнится следующий цикл: i:=12; Repeat i:=i – 2 Until i>4 . Сколько раз выполнится цикл: i:=4; while i<10 do i:=i+3 . Чему будет равна переменная sum после выполнения фрагмента программы:sum:=0; i:=1; Repeat Sum:=sum+3; i:=i – 1 Until i>11 . Составить программу, выводящую на экран значение вещественной переменной Р, равное значению выражения 〖K*D〗^(2 )/(K+D); K и D – целочисленные переменные, их значения вводятся с клавиатуры. Составить программу, запрашивающую оценки за контрольные работы по информатике и физике. Если их сумма не менее 8, то на экран должен выводится комментарий «Молодец», в противном случае – «Постарайся». Составить программу нахождения суммы квадратов натуральных чисел от 15 до 25.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

garunkhachatryan
arbat
Alesander-Isaev684
keshka12719
fouettearoma
charlie79
kozhevniks
kategar
Urmanov19903131
alvas12828646
ziyaevak
Veselova
burylin9
bezzfamilny631
lpcck2212