nst-33764
?>

Необходимо спроектировать, протестировать и разработать систему, соответствующую нижеописанной задаче. Любая написанная программа должна включать подсказку для ввода данных , сообщение об ошибке и другую необходимую введённую ясную и понятную информацию.Любые переменные, константы и другие используемые идентификаторы должны быть обозначены.Одноклеточная амеба каждые 3 часа делится на 3 клетки. Определите численность амеб через 2, 4, 6, 8, 10…24 часа.1. Опишите модель решения поставленной задачи, соблюдая следующие пункты:a) Входные данные программыb) Выходные данные программыc) Цель проектирования программыd) Назначение программыe) Область применения программы_​

Информатика

Ответы

sergei-pletenev

Вот примерно так

Объяснение:

var

 s, s1: string;

 i, k: integer;

 

begin

 write('Введите строку: ');

 readln(s);

 //s := 'мама папа дед лес поп';

 writeln(s);

 s := s + ' ';

 i := 0;

 k := 1;

 while i < Length(s) do

 begin

   inc(i);

   if not (s[i] in [' ', ',', '-']) then  

     s1 := s1 + s[i]

      else  

   begin

     if s1[1] = s1[Length(s1)] then  

     begin

       //    writeln(s1);

       delete(s, k, Length(s1) + 1);

       //    writeln(s);

     end;  

     inc(k, Length(s1) + 1);

     s1 := '';

     //writeln(k);

   end;

 end;

 writeln(s);

end.

Garifovich Greshilova791

вот основное

Объяснение:

Середина 50-х гг. характеризуется стремительным прогрессом в области программирования. Роль программирования в машинных кодах стала уменьшаться, стали появляться языки программирования нового типа, выступающие в роли посредника между машинами и программистами. Наступило время второго и третьего поколений языков программирования.

С середины 50-х г. XX в. начали создавать первые языки программирования высокого уровня (high-level programming languages). Эти языки не были привязаны к определенному типу ЭВМ (машинонезависимы). Для каждого из них были разработаны собственные компиляторы. Компиляция — трансляция программы, составленной на исходном языке высокого уровня, в эквивалентную программу на низкоуровневом языке, близком машинному коду (абсолютный код, объектный модуль, иногда язык ассемблера).

Достоинства языков программирования высокого уровня:

Алфавит языка значительно шире машинного, что делает его гораздо более выразительным и существенно повышает наглядность и понятность текста;

Набор операций, допустимых для использования, не зависит от набора машинных операций, а выбирается из соображений удобства формулирования алгоритмов решения задач определенного класса;

Конструкции операторов задаются в удобном для человека виде;

Поддерживается широкий набор типов данных.

Недостатком языков высокого уровня является больший размер программ по сравнению с программами на языке низкого уровня. Поэтому в основном языки высокого уровня используются для разработок программного обеспечения компьютеров и устройств, которые имеют большой объем памяти. А разные подвиды ассемблера применяются для программирования других устройств, где критичным является размер программы.

Неизвестно, насколько бы ускорилось развитие программирования, если бы наработки Цузе стали доступны другим учёным в конце 40-х годов, но на практике с развитием компьютерной техники сначала получил распространение машинный язык. С его программист мог задавать команды, оперируя с ячейками памяти, полностью используя возможности машины. Суть этого языка — набор кодов, обязательно понятных процессору, к которому обращаются. Части («слова») этого языка называются инструкциями, каждая из которых представляет собой одно элементарное действие для центрального процессора, как, например, считывание информации из ячейки памяти. Лишь при понимании устройства компьютерного оборудования и знания этих целочисленных кодов можно было непосредственно управлять процессором. Тогда ещё компьютеры были простыми вычислительными машинами, применяемыми для различных математических расчётов. Но они развивались, а использование большинства компьютеров на уровне машинного языка затруднительно, особенно сложным было чтение и модификация подобных программ, что усугублялось использованием абсолютной адресации памяти[3]. Поэтому со временем от использования машинных кодов пришлось отказаться.

Например, для организации чтения блока данных с гибкого диска программист может использовать 16 различных команд, каждая из которых требует 13 параметров, таких как номер блока на диске, номер сектора на дорожке и т. п. Когда выполнение операции с диском завершается, контроллер возвращает 23 значения, отражающие наличие и типы ошибок, которые необходимо анализировать. Уже одно обращение к процессору громоздко, а анализ ошибок и вовсе представляется невообразимым, особенно, если не именно с этим процессором приходиться работать. Таким образом, набор команд машинного языка сильно зависит от типа процессора.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Необходимо спроектировать, протестировать и разработать систему, соответствующую нижеописанной задаче. Любая написанная программа должна включать подсказку для ввода данных , сообщение об ошибке и другую необходимую введённую ясную и понятную информацию.Любые переменные, константы и другие используемые идентификаторы должны быть обозначены.Одноклеточная амеба каждые 3 часа делится на 3 клетки. Определите численность амеб через 2, 4, 6, 8, 10…24 часа.1. Опишите модель решения поставленной задачи, соблюдая следующие пункты:a) Входные данные программыb) Выходные данные программыc) Цель проектирования программыd) Назначение программыe) Область применения программы_​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

evageniy79
dashkevich-76611
Viktoriya
SaraevaTretyakov1941
office3
tochkamail7
Levinalx4938
Викторовна
vmnk38
Varagyant
milkline-nn
m-zolotukhina2
Matveevanastya0170
chavagorin
denbelousov963