zimin0082
?>

Задача 1. Создать программу для формирования таблицы умножения (таблицы ПифагораProgram Piphagor;Uses crt;var i, j:byte;a: array [1..9, 1..9] of integer;beginclrscr;{шапка таблицы Пифагора}for i:=1 to 9 do write(i:3, ' |'); writeln;for i:=1 to 9 do write('+'); writeln;{сама таблица}for i:=2 to 9 dobeginfor j:=1 to 9 dobegina[i, j]:=i*j;write(a[i, j]:3, ' |');end;writeln;end;readln;end.Пример № 2.Составить программу, которая в двумерном массиве случайных чисел находит в каждой строке наибольший элемент и записывает его в одномерный массив.m – количество строк в двумерном массиве и длина одномерного массива;n – количество столбцов;A[1..m, 1..n] - двумерный массив;B[1..m] – одномерный массивmax – вс переменная для нахождения наибольшего элемента в каждой строке.Program max_str;Uses crt;сonstm=5;n=6;var i, j:byte;a: array [1..m, 1..n] of integer;b: array [1..m] of integer;max: integer;beginclrscr;randomize;for i:=1 to m dobeginfor j:=1 to n dobegina[i, j]:=random(100);write(a[i, j]:4);end;writeln;end;writeln ('Массив из максимальных значений в строках:');for i:=1 to m dobeginmax:=a[i, 1];for j:=2 to n dobeginif a[i, j]>max then max:=a[i, j];end;b[i]:=max;write (b[i]:4);end;readln;end.

Информатика

Ответы

tanu0618
Uses crt;
const
q=1000;var
a:array[1..q,1..q]of integer;
m,n,i,j,c,k,buf:integer;
b:array[1..q]of integer;
begin 
   writeln('n,m ?')   ;
   readln(n,m);
    writeln('как заполнять матрицу ?');     
    writeln(' Нажмите 1 при датчика, 2 - ввод с клавиатуры'); 
{выбор действия при заполнении}                        
readln(c);   
              case c of         
                 1:for i:=1 to n do
                        begin
                            for j:=1 to m do
                               begin
                                   a[i,j]:=random(100);
                                    write(a[i,j]:4);
                                end;
                              writeln;
                         end;
                   2:
                    begin
                     for i:=1 to n do
                        begin
                            for j:=1 to m do
                              readln(a[i,j]);
                         end;
                          clrscr;
                       for i:=1 to n do
                           begin
                               for j:=1 to m do
                                  write(a[i,j]:4);
                               writeln;
                           end;
    end;
                 end;
writeln('формирование массива');
for i:=2 to n do
    begin
       if i mod 2=0 then
               for j:=1 to m do
                     if a[i,j]>2 then
                          begin
                              k:=k+1;
                               b[k]:=a[i,j];
                           end;
      end;
writeln;
for i:=1 to k do
    write(b[i]:4);
writeln;
{сортировка}
for i:=1 to k -1 do
     for j:=i+1 to k do
         if b[i]<b[j]then
             begin
                   buf:=b[i];
                   b[i]:=b[j];
                   b[j]:=buf;
             end;
{вывод массива}
for i:=1 to k do
    write(b[i]:4);
end.
                         
                    
                        
Shitikov-M.A.1307
Var
    a: array [,] of integer;

begin
    var n := ReadlnInteger('n = ');
    var m := ReadlnInteger('m = ');
    var rand := ReadlnInteger('Для ручного ввода нажмите 0');
    
    if rand = 0 then begin
        a := new integer[m, n];
        for var i := 0 to m-1 do
            for var j := 0 to n-1 do
                a[i, j] := ReadlnInteger('a[' + i + ',' + j + '] = ');
    end
    else a := MatrixRandom(m, n, 1, 100);
    Println(a);
    
    var b := ArrGen(n, x -> 1);
    for var i := 0 to m-1 do
        for var j := 0 to n-1 do
            if j mod 2 = 0 then
                b[j] := b[j] * a[i, j];
    
    b.Where((x, i)-> i mod 2 = 0).SortedDescending().Println();
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача 1. Создать программу для формирования таблицы умножения (таблицы ПифагораProgram Piphagor;Uses crt;var i, j:byte;a: array [1..9, 1..9] of integer;beginclrscr;{шапка таблицы Пифагора}for i:=1 to 9 do write(i:3, ' |'); writeln;for i:=1 to 9 do write('+'); writeln;{сама таблица}for i:=2 to 9 dobeginfor j:=1 to 9 dobegina[i, j]:=i*j;write(a[i, j]:3, ' |');end;writeln;end;readln;end.Пример № 2.Составить программу, которая в двумерном массиве случайных чисел находит в каждой строке наибольший элемент и записывает его в одномерный массив.m – количество строк в двумерном массиве и длина одномерного массива;n – количество столбцов;A[1..m, 1..n] - двумерный массив;B[1..m] – одномерный массивmax – вс переменная для нахождения наибольшего элемента в каждой строке.Program max_str;Uses crt;сonstm=5;n=6;var i, j:byte;a: array [1..m, 1..n] of integer;b: array [1..m] of integer;max: integer;beginclrscr;randomize;for i:=1 to m dobeginfor j:=1 to n dobegina[i, j]:=random(100);write(a[i, j]:4);end;writeln;end;writeln ('Массив из максимальных значений в строках:');for i:=1 to m dobeginmax:=a[i, 1];for j:=2 to n dobeginif a[i, j]>max then max:=a[i, j];end;b[i]:=max;write (b[i]:4);end;readln;end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Chistova-Dmitrii1162
departed744
Эдгеева219
kisa-luba
optikaleks7
mirsanm26249
domtorgvl20082841
gabbro19975650
Konstantinovich alekseevna993
maglevanyycpt
Alex-kustov
Anait_Natalya451
llipskaya
rusvicktor
impuls20125948