hellomaxim
?>

Решите. Нужны пояснения и вычисления, а не ответы. Итоговая контрольная работа по Информатике по программе 9 класса 3 вариант 1. Определите значение переменной a после выполнения данношо алгоритма: a := 7 с := 3 с := 3 + a * с a := с / 3 * a 2. Определите, что будет напечатано в результате работы следующей программы. Var s, k: integer; Begin s := 100; for k := 1 to 9 do s := s - 5; write (s); End. 3. В таблице Work хранятся данные о количестве заказов, принятых фирмой «Алоэ» с первого по 15 ноября. (Work[1] − число заказов, принятых 1 ноября, Work[2] − 2 ноября и т. д. Определите, какое число будет напечатано в результате работы следую-щей программы. Var k, m: integer; Work: array[1..15] of integer; Begin Work[1] := 5; Work[2] := 4; Work[3] := 5; Work[4] := 7; Work[5] := 6; Work[6] := 12; Work[7] := 7; Work[8] := 3; Work[9] := 9; Work[10] := 7; Work[11] := 0; Work[12] := 9; Work[13] := 1; Work[14] := 0; Work[15] := 8; m := 0; For k := 1 to 15 Do If Work[k] < 7 Then Begin m := m + 1; End; Writeln(m); End. 4. Сформулируйте условие задачи (что делает программа?) var n, s, k, g: integer; begin s:=0; readln(n); for k:=1 to n do begin readln(g); if (g mod 10 = 3) then s:=s+g; end; writeln(s); end.

Информатика

Ответы

ilyagenius
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var m,n:integer;
  Write('Количество строк и столбцов матрицы: ');
  Read(n,m);
  var a:=MatrixRandom(n,m,10,99);
  for var i:=0 to n-1 do begin
    for var j:=0 to m-1 do Print(a[i,j]);
    Writeln
    end;
  var p:=ReadInteger('Введите число Р:');
  var b:array of integer;
  SetLength(b,4*m);
  var k:=0;
  for var i:=n-p to n-1 do
    for var j:=0 to m-1 do
      if a[i,j] mod 4=0 then begin
        b[k]:=a[i,j]; Inc(k)
        end;
  SetLength(b,k);
  b.Print
end.

Тестовое решение:
Количество строк и столбцов матрицы: 6 8
67 70 68 72 38 72 96 38
49 75 24 55 72 63 21 40
72 12 60 22 74 30 13 45
22 45 39 24 35 97 64 31
76 62 15 94 56 28 31 13
41 67 75 37 67 13 25 20
Введите число Р: 4
72 12 60 24 64 76 56 28 20
vladimir686
1. обратись на сайт разработчика, спроси их ли эта программа, попробуй понажимать на все функции в пиратке они явно будут не все работать.
2.Если ты купила программу в обычном браузере, можешь не беспокоиться, все не законные программы удаляют, но если ты зашёл через так называемый "Tor" то уже можешь задуматься легальна ли она, ну а также можно просто посмотреть на функционал программы если там есть что-то типо "Взломать пароль" естественно это не законно.
3.обратись на сайт разработчика, спроси их ли эта программа, попробуй понажимать на все функции в пиратке они явно будут не все работать.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите. Нужны пояснения и вычисления, а не ответы. Итоговая контрольная работа по Информатике по программе 9 класса 3 вариант 1. Определите значение переменной a после выполнения данношо алгоритма: a := 7 с := 3 с := 3 + a * с a := с / 3 * a 2. Определите, что будет напечатано в результате работы следующей программы. Var s, k: integer; Begin s := 100; for k := 1 to 9 do s := s - 5; write (s); End. 3. В таблице Work хранятся данные о количестве заказов, принятых фирмой «Алоэ» с первого по 15 ноября. (Work[1] − число заказов, принятых 1 ноября, Work[2] − 2 ноября и т. д. Определите, какое число будет напечатано в результате работы следую-щей программы. Var k, m: integer; Work: array[1..15] of integer; Begin Work[1] := 5; Work[2] := 4; Work[3] := 5; Work[4] := 7; Work[5] := 6; Work[6] := 12; Work[7] := 7; Work[8] := 3; Work[9] := 9; Work[10] := 7; Work[11] := 0; Work[12] := 9; Work[13] := 1; Work[14] := 0; Work[15] := 8; m := 0; For k := 1 to 15 Do If Work[k] < 7 Then Begin m := m + 1; End; Writeln(m); End. 4. Сформулируйте условие задачи (что делает программа?) var n, s, k, g: integer; begin s:=0; readln(n); for k:=1 to n do begin readln(g); if (g mod 10 = 3) then s:=s+g; end; writeln(s); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

teya07
Leonidovich_Elena771
Дмитрий-Олейникова
shilinmikhaillg
germanleon
osipovasalex5316
Сурат1199
ПетровичЖивотовская1245
tcmir
Андрееевич787
e-s-i-k
puchkovajulia
yurievaalxndra55
Александр Сергей
merzlikinairena