Поделитесь своими знаниями, ответьте на вопрос:
Составить алгоритм и написать программу с использованием визуальных компонентов в среде разработки Visual C# в соответствии с индивидуальным заданием. Программа должна быть написана таким образом, что в поля редактирования пользователь может вводить только правильные данные – дробные числа или целые числа (в зависимости от задания Написать программу возведения в квадрат комплексного числа в алгебраической форме.
#include <conio.h>
#include <time.h>
using namespace std;
void main()
{
srand(time(NULL));
setlocale(0, "");
int arr[17];
int a, b, chet=0, nechet = 0;
cout << "Введите диапазон ." << endl << "Нижняя граница диапазона: "; cin >> a; cout << "Верхняя граница диапазона: "; cin >> b; cout << endl;
for (int i = 0; i < 17; ++i)
{
arr[i] = a + rand() % (b-a+1);
cout <<" "<<arr[i];
}
for (int i = 0; i < 17; ++i)
{
if (arr[i] % 2 == 0) chet++;
else nechet++;
} if (chet > nechet)
cout << " \n Четных больше";
else if (nechet>chet)
cout << "\n Нечетных больше";
else cout << "\n Одинаковое количество четных и нечетных";
_getch();
}