Николаевич
?>

2. Чему будет равно значение целой переменной «а» после выполнения этого фрагментапрограммы?a = 81for i in range (4):а

Информатика

Ответы

VladimirovnaViktorovich

ответ: a = 75

Так как в цикле произойдет a -= 6

dnikolay365

1.

const n=10;

var a:array [1..n] of integer;

i:integer;

begin

for i:= 1 to n do read (a[i]);

write('                           Массив: ');

for i:= 1 to n do write (a[i],'  ');

writeln;

write('Массив в обратной последовательности: ');

for i:= n downto 1 do write (a[i],'  ')

end.

2.

const n=10;

var a:array [1..n] of integer;

i,s:integer;

begin

for i:= 1 to n do read (a[i]);

write('Массив: ');

for i:= 1 to n do write (a[i],'  ');

writeln;

write ('Номера нулевых элементов: ');

for i:= 1 to n do if a[i]<0 then

begin

a[i]:=0;

write(i,' ')

end

end.

3.

const n=10;

var a:array [1..n] of integer;

i,sp,kp,so,ko:integer;

begin

for i:= 1 to n do read (a[i]);

write('Массив: ');

for i:= 1 to n do write (a[i],'  ');

writeln;

for i:= 1 to n do

begin

if a[i]>0 then

begin

sp:=sp+a[i];

kp:=kp+1

end;

if a[i]<0 then

begin

so:=so+a[i];

ko:=ko+1

end;

end;

writeln('Среднее арифметическое положительных элементов массива равно ',sp/kp:0:3);

writeln('Среднее арифметическое отрицательных элементов массива равно ',so/ko:0:3)

end.

litlenet
1.
uses crt;
const n=20;
var i,cp1,cn1:integer;
p,cp,cn:real;
z:array[1..n] of integer;
begin
randomize;
for i:=1 to n do
begin
z[i]:=random(20,-20);
if z[i]>=0 then
begin
cp:=cp+z[i];
cp1:=cp1+1;
end
else
begin
cn:=cp+z[i];
cn1:=cn1+1;
end;
cp:=cp/cp1;
cn:=cn/cn1;
end;
if cp>cn then
p:=cp+cn
else
p:=cp*cn;
for i:=1 to n do
write(z[i],' ');
writeln(#13#10,cp:5:2,' ',cn:5:2,' ',p:5:2);
end.
2.
uses crt;
const n=15;m=4;
var i,j,k,flag,count:integer;
a:array[1..n,1..m] of integer;
temp:array[1..100] of integer;
b:array[1..100,1..m] of integer;
begin
randomize;
k:=1;
count:=0;
for i:=1 to n do
begin
flag:=1;
for j:=1 to m do
begin
a[i,j]:=random(51,1);
if (a[i,j]<10) or (a[i,j]>40) then
flag:=0
end;
if flag=1 then
begin
temp[k]:=i;
count:=count+1;
k:=k+1;
end;
end;
for i:=1 to count do
for j:=1 to m do
b[i,j]:=a[temp[i],j];
writeln('Массив A:');
for i:=1 to n do
begin
for j:=1 to m do
write(a[i,j],' ');
write(#13#10);
end;
if count=0 then
writeln('Нет подходящих строк.')
else
begin
writeln(#13#10,'Массив B:');
for i:=1 to count do
begin
for j:=1 to m do
write(b[i,j],' ');
write(#13#10);
end;
end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

2. Чему будет равно значение целой переменной «а» после выполнения этого фрагментапрограммы?a = 81for i in range (4):а
Ваше имя (никнейм)*
Email*
Комментарий*