aivanova
?>

Итоговый тест по информатике для 8 класса Вариант 2. 1. Найдите правильный вид строки заголовка: 1. Programm grant; 2. Program grant2; 3. Program ugrant 4. Program 1 grant; 2. Какое значение не может принимать переменная х если она объявлена таким образом: var x:integer 1. 5, 6 2. 12000 3. 8 4. 30246 3. Что означает знак := в языке программирования Pascal? 1. Равенство; 2. Сравнение; 3. Присваивание; 4. Деление; 4. Записать на языке Pascal следующее выражение: y=5x^2+10x+2; 1. Y:=5x*2+10x+2 2. Y:=5*x*x+10x+2 3. Y:=5*x*x+10*x+2 4. Y:=5x*x+10x+2 5. Какое значение будет иметь переменная b после выполнения следующего фрагмента программы: a:=4; b:=2; a:=a*b*b; b:=a+b; 1. 32 2. 34 3. 20 4. 18 6. Какое служебное слово пропущено в следующем фрагменте программы a:=7; b:=3; a>b*2 do f:=0; writeln(f); 1. else 2. while 3. case 4. if 7. Определите тип данных следующего числа 3? 1. Real 2. Integer 3. Char 4. String 8. Какое значение примет переменная Х после выполнения оператора Х: = 17 div 4? 1. 4.25 2. 1 3. 4 9. Чему равно значение выражения: (1234 div 10) div 20? 1. 1 2. 3 3. 4 4. 6 10. Чему равно значение выражения: sqrt(16)*2-sqr(3)+20/5 1. -5 2. -6 3. 3 4. 6 11. Какое значение примет переменная М после выполнения следующих действий: М:=2*5-12/(2+4)+sqr(2)? 1. 16 2. 12 3. 3 4. 6 12. Определите значение переменной С после выполнения фрагмента программы. а:=80; в:=30; а:=а-в*3; If а>в then c:=а - в else c:= в - a 1. 180 2. 20 3. 70 4. -20 13. Каким служебным словом начинается операторный блок? 1. Program 2. var 3. begin 4. writeln 5. readln 14. Для того чтобы ввести числа с клавиатуры необходимо использовать команду? 1. writeln 2. readln 3. random 4. case 15. Чему будет равно значение переменной К после выполнения следующих действий? K:=10; S:=K+K-5; K:=S; S:=k-10; 1. 10 2. 5 3. 25 4. 15 16. Какое значение примет переменная G после выполнения действия G:=48/2-4? 1. 24 2. 20 3. 8 4. 2 17. Какое значение примет переменная М после выполения действия М:=20/10+2*(sqrt(4)*20)? 1. 80 2. 41 3. 82 4. 40 18. Имеется условный оператор: If D>10 Then writeln (`Ура`) Else writeln (`Плохо…`); Что будет выведено на экран, если D=50? 1. Плохо… 2. Ура 19. Какое значение примет переменная С в результате выполнения программы: Var A, B, C: integer; Begin A:=10; B:=A*3-6; If B>2*A Then A:=2; IF B<2*A Then A:=5; If B=2*A Then A:=B-A; C:=A*B+A-B; Writeln (`C=`, C); End. 1. 108 2. 106 3. 29

Информатика

Ответы

fta1309
{с клавиатуры вводится число до тех пор, пока не будет введено 3-х значное, сумма первых двух цифр записывается в a, сумма десятков и единиц - в b. Сравнивается какое из них больше и выводится в порядке возрастания}
Uses Crt;
var
a,c,b:integer;
begin
   ClrScr;
      repeat
          writeln('INPUT 3-x znachoe');
           readln(b);
      until (b>=100)and(b<=999);
a:=b div 100+(b div 10)mod 10;
c:=(b div 10)mod 10+b mod 10;
     if a<c then
         writeln(a,c)
else
         writeln(c,a);
Readkey;
end.
Александр Джабраиловна1967
DECLARE FUNCTION f# (x AS DOUBLE)
DECLARE FUNCTION Integ# (a AS DOUBLE, b AS DOUBLE, n AS LONG)

'Main program
DIM eps AS DOUBLE, n AS LONG, s AS DOUBLE, s1 AS DOUBLE
DIM a AS DOUBLE, b AS DOUBLE
CLS
a = 0: b = 1: eps = .001
n = 100
s = Integ#(a, b, 10#)
DO
   s1 = s
   s = Integ#(a, b, n)
   n = n * 2
LOOP UNTIL ABS(s - s1) <= eps
PRINT s
END

FUNCTION f# (x AS DOUBLE)
   f# = x ^ 3 * EXP(x ^ 2)
END FUNCTION

FUNCTION Integ# (a AS DOUBLE, b AS DOUBLE, n AS LONG)
   DIM h AS DOUBLE, xb AS DOUBLE, x AS DOUBLE
   DIM s AS DOUBLE, i AS INTEGER
   h = (b - a) / n
   s = 0
   xb = a
   FOR i = 0 TO n - 1
      x = xb + i * h
      s = s + f(x) * h
   NEXT i
   Integ# = s
END FUNCTION

Результат выполнения программы:
 .4991509793572241
Погрешность не превышает 0.001 при контрольном значении, равном 0.5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Итоговый тест по информатике для 8 класса Вариант 2. 1. Найдите правильный вид строки заголовка: 1. Programm grant; 2. Program grant2; 3. Program ugrant 4. Program 1 grant; 2. Какое значение не может принимать переменная х если она объявлена таким образом: var x:integer 1. 5, 6 2. 12000 3. 8 4. 30246 3. Что означает знак := в языке программирования Pascal? 1. Равенство; 2. Сравнение; 3. Присваивание; 4. Деление; 4. Записать на языке Pascal следующее выражение: y=5x^2+10x+2; 1. Y:=5x*2+10x+2 2. Y:=5*x*x+10x+2 3. Y:=5*x*x+10*x+2 4. Y:=5x*x+10x+2 5. Какое значение будет иметь переменная b после выполнения следующего фрагмента программы: a:=4; b:=2; a:=a*b*b; b:=a+b; 1. 32 2. 34 3. 20 4. 18 6. Какое служебное слово пропущено в следующем фрагменте программы a:=7; b:=3; a>b*2 do f:=0; writeln(f); 1. else 2. while 3. case 4. if 7. Определите тип данных следующего числа 3? 1. Real 2. Integer 3. Char 4. String 8. Какое значение примет переменная Х после выполнения оператора Х: = 17 div 4? 1. 4.25 2. 1 3. 4 9. Чему равно значение выражения: (1234 div 10) div 20? 1. 1 2. 3 3. 4 4. 6 10. Чему равно значение выражения: sqrt(16)*2-sqr(3)+20/5 1. -5 2. -6 3. 3 4. 6 11. Какое значение примет переменная М после выполнения следующих действий: М:=2*5-12/(2+4)+sqr(2)? 1. 16 2. 12 3. 3 4. 6 12. Определите значение переменной С после выполнения фрагмента программы. а:=80; в:=30; а:=а-в*3; If а>в then c:=а - в else c:= в - a 1. 180 2. 20 3. 70 4. -20 13. Каким служебным словом начинается операторный блок? 1. Program 2. var 3. begin 4. writeln 5. readln 14. Для того чтобы ввести числа с клавиатуры необходимо использовать команду? 1. writeln 2. readln 3. random 4. case 15. Чему будет равно значение переменной К после выполнения следующих действий? K:=10; S:=K+K-5; K:=S; S:=k-10; 1. 10 2. 5 3. 25 4. 15 16. Какое значение примет переменная G после выполнения действия G:=48/2-4? 1. 24 2. 20 3. 8 4. 2 17. Какое значение примет переменная М после выполения действия М:=20/10+2*(sqrt(4)*20)? 1. 80 2. 41 3. 82 4. 40 18. Имеется условный оператор: If D>10 Then writeln (`Ура`) Else writeln (`Плохо…`); Что будет выведено на экран, если D=50? 1. Плохо… 2. Ура 19. Какое значение примет переменная С в результате выполнения программы: Var A, B, C: integer; Begin A:=10; B:=A*3-6; If B>2*A Then A:=2; IF B<2*A Then A:=5; If B=2*A Then A:=B-A; C:=A*B+A-B; Writeln (`C=`, C); End. 1. 108 2. 106 3. 29
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

drozd228758
klodialeit36
tarkhanovilya
petrovichvit2933
isaev
bikemaster
saltikovaPavlenko
emaykova785
Татьяна902
genya1509
Египтян2004
batalerka391
NIKOLAI
Smolkovaya
anikamalish