gbfedak220
?>

Паскаль;Тип данных строка символов; Напишите программу, которая заменяет символ " А " символом " * "

Информатика

Ответы

ak74-81
№1
а) Результат выполнения: вывод p=75.
б) Условие: Вычислить произведение элементов массива A , кратных 5
в) См. вложение.

№2
//PascalABC.Net 3.2
begin
var a:=arrrandom (20, -10, 50); a.Println;
for var i:=0 to 19 do if (a[i] mod 5)<0 then print(a[i]);
end.

№3
begin
var t:=arrRandom(85, -40, 50);
var sum:=0;
for var i:=0 to 84 do if (t[i] mod 2)=0 then sum+=t[i];
t.Println;
for var i:=0 to 84 do if (t[i] mod 2)=0 then t[i]:=sum;
t.Println; write ('Сумма=', sum);
end.

№4
begin
var x:=readreal('Введите x =');
var y:=readreal('Введите y =');
print ('D =', min(x-21,5*y+1)-min(x*5 +2, y*4-10));
end.
Хоть с чем-то 1. для следующего фрагмента программы: program prog; uses crt; const a: array[1..8] of
Щербаков33

const g = 5; v = 3;

var a: array[1..g,1..v] of integer;

i,j,maxj,minj,p:integer;

begin

writeln('Массив: ');

for i:=1 to g do

begin

for j:=1 to v do

begin

a[i,j]:=Random(101);

write(a[i,j]:4)

end;

writeln

end;

for i:=1 to g do

begin

maxj:=1;

minj:=1;

for j:=1 to v do

begin

if a[i,j]>a[i,maxj] then maxj:=j;

if a[i,j]<a[i,minj]then minj:=j;

end;

p:=a[i,maxj];

a[i,maxj]:=a[i,minj];

a[i,minj]:=p;

end;

writeln;

writeln('Преобразованный массив: ');

for i:=1 to g do

begin

for j:=1 to v do write(a[i,j]:4);

writeln

end;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль;Тип данных строка символов; Напишите программу, которая заменяет символ " А " символом " * "
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Светлана308
YaroslavSerganYS5
Pochkun-Oleg
annarom1306
magazin3000
Лилин1079
Coffee3862
Magnolia200872
nadjasokolova2017
olimov9
Natalya1070
fokolimp
sedalex
denblacky
kononenko-elena4