oyudina
?>

Составить программу вывода на экран квадратов всех целых чисел от a до b. Пример вывода результата: 2-4 3-9 4-16 итд

Информатика

Ответы

Валентинович133

// PascalABC.NET 3.6.3

begin

 var (a, b) := ReadInteger2('Введите a и b');

 (a..b).Select(p -> p + '-' + p * p).PrintLines

end.


Составить программу вывода на экран квадратов всех целых чисел от a до b. Пример вывода результата:
cheberyako2013
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <conio.h>

int main() {
   double a, b, y;
   int x;

   a = 6.72f;
   b = 4.85f;
   printf("vvedite x=");
   scanf("%d", &x);

   switch (x) {
       case 1: y = 1 + sqrt(a + abs(x)); break;
       case 7: y = 2 + a*a*x*x + exp(x); break;
       case 5: y = x*sqrt(1+b*log(a*a*x)); break;
       default:
          printf("znachenie x zadano neverno\n");
          printf("nagmi Enter\n");
          getch();
          return 0;
   }

   printf("x=%2dy=%5.2lf", x, y);
   getch();
   return 0;
}
eugene869154
#include <cstdlib>#include <iostream>#include <iomanip>#include <cmath>
using namespace std;
int main(){    setlocale(0, "");    double x, y, a, b, xk, xn, dx;    a = 1.4;    b = 2.5;    cout << "Ââåäèòå xn,xk, dx = " << endl;    cin >> xn; cin >> xk; cin >> dx;    x = xn;    cout << "Tabl" << endl;    cout << "+-----------+" << endl;    cout << "¦ x ¦ y ¦" << endl;    while (x <= xk)          {             y = (log10(a*x*x+b))/(a*x+1);             cout << "+-----+-----¦" << endl;             cout.setf(ios::fixed);             cout.precision(3);             cout << "¦" << x << "¦"<< y << "¦" << endl;             x = x + dx;          }    cout << "+-----------+";    system("pause");}
Переделать программу паскаль в си program lab3; var x,y,a,b,xk,xn, dx: real; begin a: =1.4; b: =2.5;

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вывода на экран квадратов всех целых чисел от a до b. Пример вывода результата: 2-4 3-9 4-16 итд
Ваше имя (никнейм)*
Email*
Комментарий*