Fedorov1283
?>

Составьте программу, которая определяет, принадлежит ли точка А(x0, y0) графику функции y = 2x – 3.

Информатика

Ответы

siren89

Без проверок код был бы намного меньше, но сделал с проверками на всякий случай. Если нужно проще - пишите. По сути достаточно функции calculate_cost. И я ещё другую функцию сделал calculate_cost_old, она не используется, но в ней дифференцированный подход вычислений используется, то есть до нижней границы вычисляется по ставке 1,1, дальше вычисляется по тарифу, а больше верхней границы по тарифу 0,9. Мне кажется, так логичнее:

def calculate_cost(N:int,A:int,B:int,T:float):

   s = 0

   if N <= A: s = 1.1*N

   elif A < N <= B: s = N

   else: s = 0.9*N

   return round(T*s,2)

def calculate_cost_old(N:int,A:int,B:int,T:float):

   """Данная функция вычисляет стоимость услуг и возвращает значение"""

   s1 = 0

   s2 = 0

   s3 = 0

   # вычислим стоимость до нижней границы включительно

   if N <= A: s1 = 1.1*N

   else: s1 = 1.1*A

   # вычислим стоимость между нижней (исключительно) и верхней (включительно) границами

   if A < N <= B: s2 = N-A

   elif N > B: s2 = B-A

   # вычислим стоимость от верхней границы (исключительно)

   if N > B: s3 = 0.9*(N-B)

   

   return round(T*(s1+s2+s3),2)

def calculator():

   """основная функция"""

   names = ['Количество минут', 'Нижняя граница тарифа', 'Верхняя граница тарифа', 'Стоимость тарифа']

   while True:

       chk = True

       a = list(map(str, input('Начните ввод: ').split()))

       if len(a) != 4:

           print('Ошибка ввода: введите четыре параметра через пробел')

           continue

       for i in range(len(a)):

           if i != 3:

               try:

                   a[i] = int(a[i])

                   if a[i] < 0: raise ValueError

                   if i == 2 and a[i-1] > a[i]: raise ValueError

               except ValueError:

                   print(f'Ошибка ввода: значение "{names[i]}" ({i+1}-й параметр) должно быть целым не отрицательным числом', '> нижней границы' if i == 2 else '')

                   chk = False

           else:

               try:

                   a[i] = float(a[i])

                   if a[i] <= 0: raise ValueError

               except ValueError:

                   print(f'Ошибка ввода: значение "{names[i]}" ({i+1}-й параметр) должно быть целым положительным числом')

                   chk = False

       if chk: break

   print()

   print('--- Рассчёт окончен ---')

   print('Стоимость учлуг составляет: {:.2f}'.format(calculate_cost(a[0],a[1],a[2],a[3])))

   print()

print('--- Рассчёт стоимости услуг связи ---')

print()

print('Введите через пробел: \n  - количество потраченных за месяц минут (целое число >= 0)\n  - нижнюю границу тарифа (целое число >= 0)\n  - верхнюю границу тарифа (целое число >= нижней границы)\n  - стоимость (вещественное число > 0)')

print()

while True:

   calculator()

   if input('Повторить вычисления? (y/n): ') == 'n': break

Umkatoys50
Жил был в памяти маленький Бит. Он был очень одиноким и по этому сильно грустил, как то раз он пошел искать себе друзей.  Идет он из микропроцессора древнего в страну памяти Оперативной по пути осматривая удевительный мир системной шины. Долго бродит Бит по шине, пока однажды не нашел Ячейку!Зайдя в ячейку Бит удивился, там было еще семь таких же одиноких малышей как и он сам (и всех их звали Бит LOL) и стали они дружить и стали звать их Байт!Но друзья подумали, а что, если есть еще такие же одинокие малыши, какими были раньше мы сами? Как они справятся с этой бренной жизьню в одиночку, без и заботы? И решили тогда они восьмером что-бы то нистало, найти всех одиноких Битов и обьеденить их, что-бы жить всем вместе годы...Спустя всё это время наши маленькие друзья все искали одиноких Битов, и их становилось всё больше, они обьеденялись в Байты, а затем и в Мегабайты.Однажды их количество перевалило за Гигабайт, но друзья не останавливались и всё искали и искали, искали и искали, пока...
Нехватка системной памяти. Конец.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая определяет, принадлежит ли точка А(x0, y0) графику функции y = 2x – 3.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vasilii1891
Aleks120498
osandulyak
Голосова-Лобанов1555
bykovaam
Картузов-Алексей1252
sarbaevmax
jenn055
tenvalerij
Talikova164
Stefanidi_Semeikina1896
Nzharenikova
morozmd
ziyaevak
dshi67orbru