ambstroy
?>

Напишите программу, которая осуществляет ввод целых чисел (ввод осуществляется до тех пор, пока не будет введен ноль) и подсчет введенных отрицательных чисел язык програмированния паскаль надо

Информатика

Ответы

Тимур

// PascalABC.NET

begin

 ReadSeqIntegerWhile(p -> p <> 0).Count(p -> p < 0).Print

end.

vik-2202

Объяснение:

Программы буду писать на языке Python3

Задание 1

a = int(input("Введите число")

b = a**2

c = a**3

print("Число во второй степени:",b)

print("Число в третьей степени:", c)

Задание 2

Тут я не понял что подразумевается под словом СЛОЖНЫЕ мат. выражения. В Интернете информация которую я не проходил ещё в школе. Поэтому я программу решающее простые математические выражение. Это самый простой калькулятор на языке Питон 3.

a=int(input("первое число :"))

b=int(input("выберите знак(+\-\*\/):"))

c=int(input("второе число :"))

if b == "+":

d = a+c

elif b == "-":

d = a - c

elif b == "*":

d = a * c

elif b == "/":

d = a / c

else:

print("Вы ввели неверное значение!")

print(d)

Задание 3

i = int(3) #целые числа (integer)

f = float(4.0) #дробные числа (float)

s = school #строковый тип (string)

b = True #логический тип данных (bool)

a = [1,2,3]#список

d = {1:'value', 'key':2} #словарь

print("целые числа (integer): ", i)

print("дробные числа (float): ", f)

print("строковый тип (string): ", s)

print("логический тип данных: True")

print("список: ", a)

print("словарь: ", d)

Надеюсь на все ответил верно :). Если все верно, то отметь как лучший ответ ;)

h777eta

В PascalABC.NET есть много что готового. В частности, используя новые возможности, можно записать всё одной (вернее, двумя) строчками:

Код (PascalABC.NET):

##

ArrRandomInteger.Select((val, ind) -> Format('a[{0}] = {1}', ind, val)).Print(NewLine)

Пример вывода:

a[0] = 83

a[1] = 6

a[2] = 58

a[3] = 61

a[4] = 64

a[5] = 49

a[6] = 59

a[7] = 9

a[8] = 83

a[9] = 75

Более традиционный (в стиле "старого Паскаля") подход можно реализовать, например, так:

Код (PascalABC.NET):

var

 a: array[1..10] of integer;

 i: integer;

begin

 for i := 1 to 10 do

 begin

   a[i] := random(101);

   writeln('a[', i, '] = ', a[i]);

 end;

end.

Пример вывода:

a[1] = 7

a[2] = 21

a[3] = 15

a[4] = 78

a[5] = 91

a[6] = 72

a[7] = 63

a[8] = 56

a[9] = 38

a[10] = 81

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая осуществляет ввод целых чисел (ввод осуществляется до тех пор, пока не будет введен ноль) и подсчет введенных отрицательных чисел язык програмированния паскаль надо
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Apresov
maisa1991
julichca68
barg562
anadtacia03108988
info36
Svetlana1877
Belov
vasiliiparshin7668
Galina-Marat1096
сергей1246
Маркина Ворошилина
silviya
tvtanya80
Калмыкова-Петрунина
▲