grigoriev8
?>

ИНФОРМАТИКАCLSp=1FOR i=2 TO 7 STEP 2p=p*3PRINT pNEXT iЗапишите значение переменной P, полученное в результате работы программы.Сколько чисел будет распечатано на экране?​

Информатика

Ответы

snab54

1.

var arr: array[1..6] of integer;

var i, summ: integer;

begin

 summ:= 0;

 for i:=1 to 6 do

 begin

   readln(arr[i]);

 end;

   

 for i:=1 to 6 do

   begin

       if arr[i]>4 then

           summ := summ+arr[i];

   end;

   

 writeln(summ);

end.

var arr: array[1..7] of integer;

var i, mult: integer;

begin

 mult:= 1;

 for i:=1 to 7 do

 begin

   readln(arr[i]);

 end;

   

 for i:=1 to 7 do

   begin

       if arr[i]>0 then

           mult := mult*arr[i];

   end;

   

 writeln(mult);

end.

Краткий гайд

i - переменная-счётчикarr - массив, с которым производятся операцииsumm - (в первом задании - переменная, отвечает за сумму элементовmult - (во второй части) отвечает за произведение
ramzaev09

Const

    n = 12;

var

    i, p: integer;

    a: array[1..n] of integer;

begin

    p := 1;

    for i := 1 to n do

    begin

        a[i] := random(150) - 100;

        write(a[i], ' ');

        if a[i] > 0 then p := p * a[i];

    end;

    writeln;

    writeln('P = ', p);

end.

2)uses crt;

var a:array [1..10] of integer;

i:integer;

begin

clrscr;

randomize;

{генерируем и выводим новый массив}

for i:=1 to 10 do

begin

a[i]:=random(9)+1;

write(a[i]:3);

end;

writeln;

{в цикле проверяем если счетчик i делится на 2 ( признак четности) то либо возводим в степень либо удваиваем}

for i:=1 to 10 do

begin

if (i mod 2=0 ) then a[i]:=a[i]*a[i]

else a[i]:=a[i]*2;

end;

{выводим конечный массив}

for i:=1 to 10 do

write(a[i]:3);

readkey;

end.

3)var arr:array[1..20] of integer;

max,q:integer;

begin

writeln ('ARRAY: ');

for q:=1 to 20 do

begin

arr[q]:=random(80);

write (arr[q]:3);

end;

max:=arr[1];

for q:=2 to 20 do

if arr[q]>max then max:=arr[q];

writeln;

writeln('MAX = ',max);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ИНФОРМАТИКАCLSp=1FOR i=2 TO 7 STEP 2p=p*3PRINT pNEXT iЗапишите значение переменной P, полученное в результате работы программы.Сколько чисел будет распечатано на экране?​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yusliva
Марина
om805633748
Tarapovskaya
Yeroshkina411
filternovo
beliaevabeliaeva-olesya35
vfilina
larisau41
Марина Федорович924
evainvest1
luksorsps20096124
iqtoy2010
Misyura_Viktoriya1683
xobby18