?>
решить задание 21 стр 148 Глава 3 Начало програмирование. 21) Цикл в фрагменте программы: P : =2; repeat P: =p*0.1 until p<0.1; Будет исполнен: а) 0 раз б) 1 раз в) 2 раза 22) Цикл в фраграменте программы: a : =1; b : =1; while a+b<8 do begin a : =a+1; b : =b+2 end; Выполниться: а) 0 раз б) 2 раза в) 3 раза г) бесконечное число раза 23. Определите значение переменных s и i после выполнения фрагмента программы: s : =0; i : =5; while i>0 do begin S : = s+i; i : =i -1; end а) s = 0, i = -1 б) s = 5, i = 0 в) s = 15, i = 0 г) s = 15, i= 0 24. Выберите фрагмент программы, в котором ищется произведение 1•2•3•4•5: а) p : =0; i : = 1; while i<=5 do i := i + 1; p: =p*i; б) p : =1; i : = 1; while i<6 do i := i + 1; p: =p*i; в) p : =1; i : = 1; while i<6 do begin p: =p*i; i :=i +1 end; г) p : =1; i : = 1; while i<5 do begin p: =p*i; i :=i +1 end; 25. В данном фоагменте программы: S : =0; for i : =1 to 10 do S:=s+2*i; а) сумма целых чисел от 1 до 10 б) сумма четных чисел от 1 до 10 в) удвоенная сумма целых чисел от 1 до 10 г) сумма первых десяти натуральных чисел
Ответы
uses crt; var a: array [1..20, 1..20] of real; i, j, k, n, s: integer; begin clrscr; write('Введите размер матрицы: '); read(n); for i := 1 to n do for j := 1 to n do begin write('A[', i, ',', j, ']= '); readln(a[i, j]); end; WRITELN; WRITELN; writeln('Исходная матрица ', n, 'x', n, ': '); for i := 1 to n do begin for j := 1 to n do WRITE(a[i, j]:2:0, ' '); WRITELN; end; k := 0; for i := 1 to n do begin for j := 1 to n do begin if a[i, j] = 0 then begin k := k + 1; s := s + 1; end; end; if k = n then writeln(i, ' строка состоит из нулей! '); k := 0; end; if s = 0 then writeln('В матрице нет нулевых строк'); end.