kapustina198690
?>

Составить блок-схему и написать программу на языке Паскаль выводящую на экран таблицу значений функции f(x) для х є [a;b] (a, b - целые, a>b) с шагом -1​

Информатика

Ответы

mbrilliantova

f(x) = x2 -2

сам решал могут быть не большие погрешности

sgritsaev

program z1;

var a,b,x: integer;

f:real;

begin

write ('a = ');

readln (a);

write ('b = ');

readln (b);

for x:=a to b do

begin  

if x>2 then f:=x*x-3

else if x<-2 then f:=x/3

else f:=abs(x-2);

writeln ('f(',x:2,') = ',f)

end

end.

Объяснение:

Смотри картинку

Это цикл для a < b c шагом 1.

Если цикл для a > b c шагом -1, то 9 строку (for x:=a to b do) заменяем на for x:=a downto b do.


Составить блок-схему и написать программу на языке Паскаль выводящую на экран таблицу значений функц
zrs-546

int n = Convert.ToInt32(Console.ReadLine())

Объяснение:

Это Ввод данных. Первые две задачи выполнены хорошо. Если хочешь вводить число n , то в вызове метода убери параметры и оставь свободным.

static void Main()

{

(10,45);

ShowSequenceOfOddNumbers(5);

CreateAndShowArray();    // Вот так

}

А чтоб вводить число добавь строку "Ввода данных"

int n = Convert.ToInt32(Console.ReadLine())

Например:

tatic void CreateAndShowArray()     // Пустой параметр

{

int n = Convert.ToInt32(Console.ReadLine())

long p = 1;

for (int i = 0; i < n; i++)

{

a[i] = new Random().Next(0, 100);

Console.Write(a[i] + " ");

p *= a[i];

}

abcd138191

Как я понимаю, так достаточно будет?

from random import choice

answer = [["1", "111"], ["2", "222"], ["3", "333"], ["4", "444"]]

print("Почему ты не хочешь ехать в деревню?")

while 1:

       input("Enter для продолжения: ")

       random_answer = choice(answer) # получаем значения после псевдо-рандома

       print(f"В деревне {random_answer[0]} = {random_answer[1]}") # выводим ответ

       answer.remove(random_answer) # удаляем из массива что бы больше не повторялось

       if len(answer) == 0: break # Выходим если ответов больше нету

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить блок-схему и написать программу на языке Паскаль выводящую на экран таблицу значений функции f(x) для х є [a;b] (a, b - целые, a>b) с шагом -1​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ASRodichev
соловьев_Куркина
vnolenev
pbttehnology
shilinmikhaillg
Railyan
merzlikinairena
tcmir
nunabat457
Aleksei1463
mbykovskiy
Григорьевич915
Anatolevich667
annakuznetsova841
verkop9