Alyona
?>

Приветик друзья с кодом, а то никак не пойму как его записать на паскаль. — Составить программу, которая формирует массив P из 24 элементов, в котором элементы с 1 по 10 являются кубами своих порядковых номеров, элементы с 10 по 24 равны периметрам квадратов со сторонами равными соответственно 10, 11, 12, …, 24. Массив вывести в строку.

Информатика

Ответы

utburt

N 1

1. 3 кбайт = 2048 байт + 7616 бит

  

 переводим 3 кбайта в байты

 A = 3 * 1000 = 3000 байт

 вычитаем любое кол-во байтов и переводим в биты (при условии C < B, C - любое      значение)

предположим С = 952

 

получаем 3 кбайт = 2048 байт + 952 * 8 бит

ответ - выше

------------

 

2. 2,56 кбайт = 2560 байт = 20480 бит

 

Решение

   20480 / 8 = 2560 / 1000 = 2,56 кбайт

------------

 

N 2

Длинная строки полученной телеграммы " встречайте вагон7 " (если вы не напутали с пробелами и расстановкой цифры) равна 19 символов (пробел тоже символ), как нам известно размер одного символа равен 8 битам или 1 байту

 

Производим обычную арифметическую операцию:

 19 * 1 = 19 байт (объем сообщения) или 19 * 8 = 152 бит 

 

N 3 

log_{2}32 = 6

тоесть 6 бит на один символ, а значит

860 * 6 = 5160 / 8 = 645 / 1000 = 0,645 кбайт

 

N 4 

Там предоставлены две кодировки, вам нужно сравнить таблицы кодировок

 

N5

Фаил = 30 кбайт 

1стр = 30 * 64 = 1,92 кбайт

округлим размер одной страницы и получим 2

Кол-во страниц = 30 / 1,92 = 15,625 окгругляем вверх

ответ 15 страниц

 

 

 

 

Владимирович111

#include <iostream>

#include <vector>

using namespace std;

int f(vector<int> &u){

   int k = 1;

   bool has_negative = false;

   for(auto &i : u){

       if(i < 0){

           k *= i;

           has_negative = true;

       }

   }

   return k * has_negative;

}

signed main(){

   const int n = 5;

   vector<vector<int>> a(n, vector<int> (n));

   for(int i = 0; i < n; i++)

       for(int j = 0; j < n; j++)

           cin >> a[i][j];

   for(int i = 0; i < n; i++)

       cout << "Product of negatives in " << i + 1 << " line is " << f(a[i]) << "\n";

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Приветик друзья с кодом, а то никак не пойму как его записать на паскаль. — Составить программу, которая формирует массив P из 24 элементов, в котором элементы с 1 по 10 являются кубами своих порядковых номеров, элементы с 10 по 24 равны периметрам квадратов со сторонами равными соответственно 10, 11, 12, …, 24. Массив вывести в строку.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

hr2251
shoko91
elenarumack
Елена
schumacher8
palchiknr
MAXIM76748
rechkai64
tanias
beliaevabeliaeva-olesya35
cat2572066
igortychinin
tgeraskina
Галина-Юлия1292
marani2