olimp201325
?>

Напишите программу, определяющую, лежит ли точка А(ха, уа) на прямой у = kx + m, над ней или под ней

Информатика

Ответы

Николаевич1033

Объяснение:

xa = int(input('Введите координату х: '))

ya = int(input('Введите координату y: '))

k = int(input('Введите коэффициент наклона: '))

m = int(input('Введите смещение: '))

if ya == k*xa + m: print('Точка лежит на прямой')

elif ya < k*xa + m: print('Точка ниже прямой')

else: print('Точка выше прямой')

NataliaBerezovskaya33
Код#include <iostream>#include <utility>#include <numeric>#include <vector>class Beast {    int trigger;    double aggression;    double rage_aggression;public:    Beast() = default;    Beast(int trigger, double aggression, double range_aggression)    : trigger(trigger), aggression(aggression), rage_aggression(range_aggression)    { }    Beast(const Beast&) = default;    Beast(Beast&&) = default;    Beast& operator=(const Beast&) = default;    Beast& operator=(Beast&&) = default;    [[nodiscard]] double calculate_aggression(unsigned long amount) const {        return amount > trigger ? rage_aggression : aggression;    }    void ReadFrom (std::istream& is) {        is >> aggression >> rage_aggression >> trigger;    }    void WriteTo(std::ostream &os) const {        os << aggression << " " << rage_aggression << " " << trigger;    }};std::istream& operator >>(std::istream &is, Beast &cls) {    cls.ReadFrom(is);    return is;}std::ostream& operator <<(std::ostream &os, const Beast &cls) {    cls.WriteTo(os);    return os;}class Cage {    double durability;    std::vector<Beast> container;public:    explicit Cage(double durability, std::vector<Beast> container)    : durability(durability), container(std::move(container))    { }    Cage(const Cage&) = default;    Cage(Cage&&) = default;    Cage& operator=(const Cage&) = default;    Cage& operator=(Cage&&) = default;    [[nodiscard]] double calculate_aggressive() const {        auto amount = container.size();        if (amount == 0) return 0;        return std::accumulate(container.begin(), container.end(), 0.0,        [amount](double total_aggressive, const Beast & beast){            return total_aggressive + beast.calculate_aggression(amount);        });    }    [[nodiscard]] bool is_it_normal() const {        auto aggressive = calculate_aggressive();        return aggressive <= durability;    }    [[nodiscard]] int get_capacity() const {        return container.size();    }    [[nodiscard]] double get_durability() const {        return durability;    }};template <typename T>void subsetsUtil(std::vector<T>& A, std::vector<std::vector<T> >& res,                 std::vector<T>& subset, int index){    res.push_back(subset);    for (int i = index; i < A.size(); i++) {        // include the A[i] in subset.        subset.push_back(A[i]);        // move onto the next element.        subsetsUtil(A, res, subset, i + 1);        // exclude the A[i] from subset and triggers        // backtracking.        subset.pop_back();    }}template <typename T>std::vector<std::vector<T>> P(std::vector<T>& A){    std::vector<T> subset;    std::vector<std::vector<T>> res;    int index = 0;    subsetsUtil(A, res, subset, index);    return res;}int main () {    int n, s;    Beast noname{};    std::vector<Beast> set_of_beasts;    std::cin >> n >> s;    for (auto i = 0; i < n; ++i) {        std::cin >> noname;        set_of_beasts.push_back(noname);    }    auto selections = P(set_of_beasts);    std::vector<Cage> variants;    std::transform(selections.begin(), selections.end(), std::back_inserter(variants), [s](std::vector<Beast> &selection){        return Cage(s, selection);    });    std::vector<Cage> true_variants;    std::copy_if(variants.begin(), variants.end(), std::back_inserter(true_variants), [](Cage& x) {return x.is_it_normal();});    auto the_best_of_the_best_variant = *std::max_element(true_variants.begin(), true_variants.end(), [](Cage & s1, Cage & s2){        return s1.get_capacity() < s2.get_capacity();    });    std::cout << the_best_of_the_best_variant.get_capacity();    return 0;}
У Арсения есть n зверьков. Каждый из них обладает характером, поэтому, если в клетке, где находится
У Арсения есть n зверьков. Каждый из них обладает характером, поэтому, если в клетке, где находится
Agadzhanyan-Ekaterina
Описание рабочего проекта
Рабочий проект - полное и окончательное решение объмно-планировочного характера, используемое для строительства зданий и сооружений. Одновременно Рабочий проект является комплектом документов, требуемых для застройки участка застройщиком.

Это необходимые расчеты конструкции сооружения с учетом всех строительных норм и правил (СНиП), ГОСТа, ДБН.

Рабочий проект является основой работы строительной организации, которая выполняет строительство объекта и является необходимым для ввода здания в эксплуатацию.

Он обычно состоит из трёх частей:

I Утверждаемая часть
Расчеты характеристик и технико-экономических показателей здания. Здесь указывается соответствие Рабочего проекта нормам и госстандартам, чтобы потом пройти в органах государственного надзора проверку и утверждение с выдачей разрешительных докеументов на начало строительства.

II Архитектурный проект
Еще называют Эскизным проектом (необязательно входит в состав Рабочего проекта и обычно исполняется в виде отдельного проекта)

Соответствие проектируемого объекта окружающим зданиям - оно не должно нарушать окружающую архитектуру, выбиваться из окружающей среды. Это версия объемного начертательного вида здания и подлежит отдельному согласованию с органами архитектуры и градостроительства. В него входят: план здания, наружные размеры здания, внутренние и поэтажные размеры с указание внутренней планировки, в цветном исполнении внешний вид объекта.

III Рабочая документация
Строительные рабочие чертежи служат основой для процесса выполнения строительных работ. Они включают в себя геометрические начертания зданий, узлы и конструкции фундаментов, стен, перекрытий и кровли. В состав рабочей документации обычно входит:

пояснительная записка по основным разделам генплана (генеральный план, градостроительная часть проектирования экстерьера и прилегающей территории) и сам генплан может выполняться отдельнам проектом
ситуационный план в масштабе 1:5000
генеральный план участка на топографической основе в масштабе 1:500(может выполняться отдельным проектом)
план благоустройства территории, план дорожных покрытий
план организации рельефа, вертикальная планировка АР (Архитектура)
план этажей
фасады
разрезы
кладочный план
план кровли
узлы по конструкциям стен, перекрытий, кровли
экспликация полов
спецификация дверных и оконных проемов
план фундаментов
планы и узлы перекрытий, фундамента, полов, лестниц
схематическое изображение индивидуальных конструктивных решений
план кровли, каркаса
планы трасс внутриплощадочных сетей и сооружений к ним
колоны, балки
приямки, подпольные каналы для смежников (каналы для коммуникаций).
планы отопления, теплых полов, вентиляции
планы систем водопровода и канализации
предусмотренные в проекте места установки устройств воздухоочистки и кондиционирования воздух
вентиляция, кондиционирование
разработка электрических, сантехнических сетей и отопления

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, определяющую, лежит ли точка А(ха, уа) на прямой у = kx + m, над ней или под ней
Ваше имя (никнейм)*
Email*
Комментарий*
▲