lika080489
?>

написать программу, которая будет считать сумму введенных с клавиатуры чисел до тех пор, пока не будет введен ноль​

Информатика

Ответы

bykovaam

var s,k:integer;

begin

s:=0;

repeat

readln(k)

s:=s+k;

until k=0;

write (s);

end.

Объяснение:

используем цикл с постусловием

Кашихина
Сначала немного теории.
--> - импликация, следование
Таблица истинности импликации

x1 x2 r
0   0  1
0  1   1
1  0   0
1  1   1
Общее правило: если x1<=x2, тогда правда, в остальных случаях ложь.
^ - Конъюнкция, логическое И
Таблица истинности конъюнкции
x1 x2 r
0   0  0
0   1 0
1   0  0
1   1  1
Общее правило: если x1 или x2 = 0, тогда ложь. x1=x2=1, только тогда правда.

(первая буква имени согласная ---> вторая буква имени согласная)^ четвертая буква имени согласная 
1) Лариса 
2) Сергей 
3) Геннадий 
4)Елена

Теперь по вариантам:
1) Лариса 
Получается (1-->0)^0=0^0=0, не подходит
2) Сергей 
(1-->0)^1=0^1=0, не подходит
3) Геннадий
(1-->0)^1=0^1=0, не подходит
4) Елена
(0-->1)^1=1^1=1, подходит
ответ: 4) Елена

Малыхин Валерьевна621

1 Центральная часть компьютера, выполняющая заданные программой преобразования информации и осуществляющая управление всем вычислительным процессом.

2 Процессоры конструктивно могут выполняться как в виде одной большой интегральной микросхемы — чипа, так и в виде нескольких микросхем, блоков электронных плат устройств.

3 Управля́ющий автома́т, устро́йство управле́ния проце́ссором — блок, устройство, компонент аппаратного обеспечения компьютеров.

4 Арифме́тико-логи́ческое устро́йство — блок процессора, который под управлением устройства управления служит для выполнения арифметических и логических преобразований над данными

5 технологический процесс изготовления полупроводниковых изделий и материалов; состоит из последовательности технологических и контрольных операций

а на шестой ответа не знаю(

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу, которая будет считать сумму введенных с клавиатуры чисел до тех пор, пока не будет введен ноль​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kalina1372
kareeva
lawyer-2019
goodsled
lalaland2744
shoko91
aksmobile
sergeylive
kampina1
nikitamihailov22095010
Алексей Кирилл1094
Kochinev4
ibswoklol1362
petrova-kate3
YuRII1236