?>
Напишите программу на Pascal, которая выведет на экран продолжениеследующих предложений: Мне было интересно… Мне было трудно… Я понял, что… Теперь я могу… Я приобрел… Я научился… У меня получилось … Я смог… Я попробую… Меня удивило…
Ответы
var b:array [1..10] of real;
min,max,x:integer;
sum,pr,t:real;
begin
sum:=0; pr:=1;
for x:=1 to 10 do
begin
write('b[',x,']:'); readln(b[x]);
end;
min:=1; max:=1;
for x:=1 to 10 do
begin
if b[x]<b[min] then min:=x;
if b[x]>b[max] then max:=x;
end;
t:=b[min];
b[min]:=b[max];
b[max]:=t;
if max>=min then
for x:=min+1 to max-1 do
sum:=sum+b[x]
else
for x:=max+1 to min-1 do
sum:=sum+b[x];
for x:=1 to 10 do
if b[x]<0 then pr:=pr*b[x];
for x:=1 to 10 do
write(b[x],' ');
writeln; writeln(sum);
writeln(pr);
end.