Мечиславович_Кварацхелия1988
?>

Составить программу, определяющую и выводящую на экран сумму и количество элементов двумерного массива размером N*M, кратных числу К. Значения К, М и N вводятся с клавиатуры, 2<М<10, 2 C++

Информатика

Ответы

djikia88

//PascalABC.NET v3.3 1633

var arr: array [1..6, 1..6] of integer;

begin

 for var i:=1 to 6 do

   for var j:=1 to 6 do

     arr[i, j]:=random(-49, 50);

 

 writeln('Исходный массив: ');

 for var i:=1 to 6 do

     arr[i].PrintLn(', ');

     

 var num:=0;

 for var i:=1 to 6 do

   if arr[i, 2] < 0 then num += 1;

 writeln('Количество отрицательных элементов второго столбца: '+num);

 

 for var i:=1 to 6 do

   for var j:=1 to 6 do

     if arr[i, j] > 0 then arr[i, j]:=-49;

 writeln('Новый массив: ');

 for var i:=1 to 6 do

     arr[i].PrintLn(', ');

end.

Вайнер

7 бит:

ASCII7 — первая кодировка, пригодная для работы с текстом. Помимо маленьких букв английского алфавита и служебных символов, содержит большие буквы английского языка, цифры, знаки препинания и другие символы.

Кодировки стандарта ASCII (8 бит):

ASCII — первая кодировка, в которой стало возможно использовать символы национальных алфавитов.

КОИ8-R — первая русская кодировка. Символы кириллицы расположены не в алфавитном порядке. Их разместили в верхнюю половину таблицы так, чтобы позиции кириллических символов соответствовали их фонетическим аналогам в английском алфавите. Это значит, что даже при потере старшего бита каждого символа, например, при проходе через устаревший семибитный модем, текст остается "читаемым".

CP866 — русская кодировка, использовавшаяся на компьютерах IBM в системе DOS.

Windows-1251 — русская кодировка, использовавшаяся в русскоязычных версиях операционной системы Windows в начале 90-х годов. Кириллические символы идут в алфавитном порядке. Содержит все символы, встречающиеся в типографике обычного текста (кроме знака ударения).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, определяющую и выводящую на экран сумму и количество элементов двумерного массива размером N*M, кратных числу К. Значения К, М и N вводятся с клавиатуры, 2<М<10, 2 C++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mayorovmisc6
Anatolevich667
chechina6646
ocik1632933
universal21vek116
Galina_Yurevna
BogdanR106203
aprilsamara2019
Galkin Vladimirovich729
ЮлияНиколаевна1748
smint056950
ivanjeka87
ktatarinova
hellomaxim
ЕВгений_денис643