char40
?>

1)Напишите программу, запрашивающую у пользователя пароль. Если пароль не совпадает с эталонным (придумайте его сами, например, «12345»), то программа возвращает пользователя на шаг ввода пароля. Данная программа должна быть выполнена с оператора Repeat…Until. 2) Напишите программу-викторину, которая задаёт три во и предлагает пользователю на них ответить. Переход на следующий во не происходит до тех пор, пока пользователь не ответит правильно на предыдущий во Переменную под ответ используйте текстовую (string Данная программа должна быть выполнена с оператора

Информатика

Ответы

brendacepedam
Var
  sme: byte;
  arrIn: array of byte;
  boolEncode: boolean;
  arrOut: System.Collections.Generic.List<byte> := new System.Collections.Generic.List<byte>();

begin
  writeln('1 - encode; 2 - decode');
  readln(sme);
  boolEncode := (sme = 1);
  write('Смещение: ');
  readln(sme);
  arrIn := System.IO.File.ReadAllBytes('out.txt');
  foreach f: byte in arrIn do
    arrOut.Add(f + (boolEncode ? -1 : 1) * sme);
  System.IO.File.WriteAllBytes('out1.txt', arrOut.ToArray());
end.

Алфавит, это, конечно, хорошо, но, бесспорно, будет лучше сделать более универтально: алфавит не только русским будет, ещё пункт. знаки, цЫфры, иврит...:)
opel81

7гтештм8штш7нтш7тшнтг7тгтпш7тштш7тш8тш8шьщьь88ь7о7о7о7о7ьшьщь7ьштиам5п 3 в в в и в в кнк5 пеенрггр ниеиеин синие ини нтгьшб лишь лишь шььш ешь ешь ешь ешь ешь ешь ешь шьЭкономика СССР была административно-командной на протяжении всей его истории. В отдельные периоды (1921-1930, 1987-1991) она "разбавлялась" элементами капиталистической экономики, позволяя частным предпринимателям торговать результатами своего труда по рыночным ценам, однако в целом не меняла своей сути. Лишь в 1990 году была законодательно разрешена частная собственность на средства производства и начался обвальный переход к рыночной экономике западного типа. Однако такой важнейший элемент административно-командной системы, как регулирование цен в государственных магазинах, просуществовал до самого распада СССР.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)Напишите программу, запрашивающую у пользователя пароль. Если пароль не совпадает с эталонным (придумайте его сами, например, «12345»), то программа возвращает пользователя на шаг ввода пароля. Данная программа должна быть выполнена с оператора Repeat…Until. 2) Напишите программу-викторину, которая задаёт три во и предлагает пользователю на них ответить. Переход на следующий во не происходит до тех пор, пока пользователь не ответит правильно на предыдущий во Переменную под ответ используйте текстовую (string Данная программа должна быть выполнена с оператора
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Barabanov Gerasimenko
Рудаков Бахтовар
annademidova-74
Boss5519
alexfold
mmurzina
nadlen76
Поликарпова-Мазурова
jgaishun756
sv455umarketing74
olgabylova6223
Рогов1996
NikolaevichIP1136
mail5
Arsen-araqelyan20164
▲