andrew409
?>

Составить программу, которая по введенному числу(в двоичной системе счисления) представляющего собой упакованную заданную структуру, формирует из нее составные части и выводит из на экран(в виде десятичного и двоичного числа15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0O O O O O C D N N N N N N N N N ​

Информатика

Ответы

tshelokova
#include <iostream>
#include <conio.h>
#include <time.h>
using namespace std;

void main()
{
 srand(time(NULL));
 setlocale(0, "");
 int arr[17];
 int a, b, chet=0, nechet = 0;
cout << "Введите диапазон ." << endl << "Нижняя граница диапазона: "; cin >> a; cout << "Верхняя граница диапазона: "; cin >> b; cout << endl;
for (int i = 0; i < 17; ++i)
{
  arr[i] = a + rand() % (b-a+1);
  cout <<" "<<arr[i];
}
for (int i = 0; i < 17; ++i)
{
  if (arr[i] % 2 == 0) chet++;
 else nechet++;
} if (chet > nechet)
 cout << " \n Четных больше";
else if (nechet>chet)
 cout << "\n Нечетных больше";
else cout << "\n Одинаковое количество четных и нечетных";
 _getch();
}
Анастасия Елена
Задание №1
60 Мбайт * 8 = 480 Мбит - размер файла в мегабитах
480 Мбит * 1024 = 491520 Кбит - размер файла в килобитах
491520 / 2 = 245760 Кбит - половина файла
245760 Кбит / 256 = 960 секунд - время передачи первой половины файла
245760 Кбит / (256 / 2) = 245760 Кбит / 128 = 1920 секунд - время передачи втораой половины файла
960 с + 1920 с = 2880 секунд - общее время передачи
В одной минуте 60 секунд:
2880 / 60 = 48 минут - передан весь файл

Задание №2
Переведем килобайты в биты: N = 3750кбайт = 30720000бит
Вычислим скорость передачи информации: V = 30720000/120
V = 256000 бит/c

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая по введенному числу(в двоичной системе счисления) представляющего собой упакованную заданную структуру, формирует из нее составные части и выводит из на экран(в виде десятичного и двоичного числа15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0O O O O O C D N N N N N N N N N ​
Ваше имя (никнейм)*
Email*
Комментарий*