Владислав-Александр32
?>

Нужно написать программу Паскаль. И если можете, объясните как с этой программой потом работать, я вообще ничего не понимаю по этому предмету

Информатика

Ответы

Ter-Pogosov_Vasilevna
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите её версию!

begin
  var b:=MatrRandom(4,4,-5,5); b.Println(3);
  var p:=1;
  var s:=0;
  Write('Элементы главной диагонали: ');
  for var i:=0 to 3 do
    for var j:=0 to 3 do
      if i<j then p*=b[i,j]
      else
        if i>j then s+=b[i,j]
        else Write(b[i,j]:3);
  Writeln(Newline,'П=',p,', S=',s)
end.

Пример
 -2 -1 -2  4
  0  1  1 -3
  0  1  5  5
  3  4  3  2
Элементы главной диагонали:  -2  1  5  2
П=-120, S=11
Терентьева

#include <iostream>

#include <vector>

using namespace std;

float summatrix(vector < vector<float>>& v) {

float s=0;

for (int i = 0; i < v.size(); i++) {

 for (int j = 0; j < v[i].size(); j++) {

  if (j > i) s += v[i][j];

 }

}

return s;

}

float mulmatrix(vector < vector<float>>& v) {

float s = 1;

for (int i = 0; i < v.size(); i++) {

 for (int j = 0; j < v[i].size(); j++) {

  if (i > j) s *= v[i][j];

 }

}

return s;

}

int main()

{

 

//создадим матрицу 5 на 5 и заполним ее случайными числами

vector < vector<float>> v1(5,vector<float>(5));

for (auto& it1 : v1) {

 for (auto& it2 : it1) {

  it2 = float(rand()%100+1)/10.0;

 }

}

//создадим матрицу 8 на 8 и заполним ее случайными числами

vector < vector<float>> v2(8, vector<float>(8));

for (auto& it1 : v2) {

 for (auto& it2 : it1) {

  it2 = float(rand()%100+1) / 10.0;

 }

}

//Выведем матрицы на экран

for (auto& it1 : v1) {

 for (auto& it2 : it1) {

  cout << it2 << " ";

 }

 cout << endl;

}

cout << endl;

for (auto& it1 : v2) {

 for (auto& it2 : it1) {

  cout << it2 << " ";

 }

 cout << endl;

}

cout << endl;

cout << "sum v1=" << summatrix(v1)<<endl;

cout << "sum v2=" << summatrix(v2) << endl;

cout << "mul v1=" << mulmatrix(v1) << endl;

cout << "mul v2=" << mulmatrix(v2) << endl;

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу Паскаль. И если можете, объясните как с этой программой потом работать, я вообще ничего не понимаю по этому предмету
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vis-lyubov8832
dearmaria
iuv61
ninaandreeva3179
Екатерина15
Александровна1742
Александрович Алексеевна
stusha78938
Konstantinovna1936
Sknyajina5
Smirnovav1982422
alina Korneev
hr2251
AndreiFaikov1943
zelreiki