delo1005
?>

1) Напишите программу, которая находит количество четырёхзначных чисел, которые делятся на 7. 2) Ипполит задумал трёхзначное число, которое при делении на 17 даёт в остатке 11, а при делении на 19 даёт в остатке 9. Напишите программу, которая находит все такие числа. 3) С клавиатуры вводится натуральное число N. Программа должна найти факториал этого числа (обозначается как N!) – произведение всех натуральных чисел от 1 до N. Например Питон.

Информатика

Ответы

varvara82193

Python

Объяснение:

3.

N = int(input())

h = 1

for  i in range(N+1):

      h= i * h

print(h)

Бунеева
1.Какое устройство компьютера моделирует мышление человека?
-Процессор

2.Действия над исходной информацией (фактами) в соответствии с некоторыми правилами - это
-обработка информации

3.Из предложенных сообщений выбрать правило
-при умножении простых дробей их числители и знаменатели перемножаются

4.Для кого, вероятнее всего, будет информативным следующее сообщение: «Программа - это алгоритм, записанный на языке программирования»?
-начинающий программист

5.Где хранится выполняемая в данный момент программа и обрабатываемые ею данные?
-в оперативной памяти

6.Какое устройство компьютера осуществляет процесс дискретизации звука?
-звуковая карта

7.Информативность сообщения, принимаемого человеком, определяется
-наличием новых знаний и понятностью

8.Вместо многоточий вставьте соответствующие понятия: «Каталог содержит информацию о ..., хранящихся в...»
A) файлах, внешней памяти

9.Указать команду(ы), при выполнении которой(ых) выделенный фрагмент попадает в буфер обмена
В) вырезать и копировать

10.Какие из перечисленных действий относятся к форматированию текста?
-установка режима выравнивания

11.В прикладное программное обеспечение входят:
В) текстовые редакторы

12.Операционная система - это
-комплекс программ, организующих управление работой компьютера и его взаимодействие с пользователем

13.Предложены команды
5Сделать диск А текущим.
2Создать каталог TOWN
3Создать каталог STREET
1Создать файл Home.txt
4Войти в созданный каталог
Расположить пронумерованные команды так, чтобы был получен алгоритм, с которого на пустой дискете создается файл с полным именем A:\TOWN\STREET\Home.txt
Б) 5,2,3,1

14.Для хранения текста требуется 84000 бита. Сколько страниц займет этот текст, если на странице размещается 30 строк по 70 символов в строке? Для кодирования текста используется таблица кодировки, состоящая из 256 символов.
84000/(log(256)/log(2))/30/70 = 5

15.Книга состоит из 64 страниц. На каждой странице 256 символов. Какой объем информации содержится в книге, если используется алфавит из 32 символов?
А) 81920 байтов Б) 40 Кбайт В)10 Кбайт Г) 16 Кбайт Д) 64 Кбайт
64*256*(log(32)/log(2)) /8/1024 = 10

16.Сколько символов содержит сообщение, записанное с символьного алфавита, если его объем составил 1/16 часть Мегабайта?
(1/16)*1024*1024*8/(log(16)/log(2)) = 131072

17.Сколько памяти занимает графическое изображение, если его размер 40x60 и для кодирования цвета пикселя используется двоичный код из 32-х битов.
А) 2400 байтов  Б) 2100 байтов  В) 960 байтов Г) 9600 байтов    Д) 12000 байтов
40*60*32/8 = 9600

18.Текст занимает 0,25 Кбайт памяти. Сколько символов содержит этот текст, если используется таблица кодировки, состоящая из 256 символов?
0.25*1024*8/(log(256)/log(2)) = 256

19.Сколько битов информации содержится в сообщении объемом четверть Килобайта?
1/4*1024*8 = 2048
Petrakova Ilyushin
Чтобы прекратить ввод чисел в массив нужно ввести число "-1".
class ArrayMiddle{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in); long eArray[] = new long[1];
  while((eArray[eArray.length-1] = in.nextLong())!=-1){
   long nArray[] = new long[eArray.length+1];
   for(int nCell = 0; nCell<eArray.length; nCell++)nArray[nCell]=eArray[nCell];
   eArray = nArray;
  } eArray[eArray.length-1] = 0;
  for(int cCell = 0; cCell<eArray.length-1; cCell++)eArray[eArray.length-1]+=eArray[cCell];
  System.out.print(eArray[eArray.length-1]/(double)(eArray.length-1));
 }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) Напишите программу, которая находит количество четырёхзначных чисел, которые делятся на 7. 2) Ипполит задумал трёхзначное число, которое при делении на 17 даёт в остатке 11, а при делении на 19 даёт в остатке 9. Напишите программу, которая находит все такие числа. 3) С клавиатуры вводится натуральное число N. Программа должна найти факториал этого числа (обозначается как N!) – произведение всех натуральных чисел от 1 до N. Например Питон.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dmitryshigin
menametov
Takhmina-Komarova1415
korj8
Васильева-Александрович
Староческуль-Станиславовна
mrropevvv
yuraotradnov
doorhan42n6868
magazin3000
Александрович Алексеевна
Виталий887
e-liza-k
iuv61
stusha78938