dariamay1996
?>

Написать программу на Паскале 1. Создать два массива: массив фамилий студентов и массив оценок. Фамилии ввести использую оператор readln, оценки используя Random. Для ввода оценок в диапазоне использовать функцию Random (2, 5Ввод и вывод должен соответствовать примеру ниже: 2 Объявить 4 массива. Создать три массива: массив фамилий студентов и массивы оценок по математике и физике. Фамилии ввести использую оператор readln, оценки используя функцию Random. Для ввода оценок в диапазоне использовать Random (2, 5). Массив, содержащий средние заполнить используя формулу вычисления среднего значения. Ввод и вывод должен соответствовать примеру ниже: 3 Внести дополнение в задачу 2, необходимо вывести количество студентов, имеющих средний >3.

Информатика

Ответы

ЮлияДаниил520
Код Pascal1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 const n=100; type arr=array[1..n] of integer; var   a:arr;   skv:real;   i,k,l:integer; procedure print(s:string;a:arr;l:integer); var   i:integer; begin   writeln(s);   write('[');   for i:=1 to l-1 do write(a[i],', ');   writeln(a[l],']'); end; procedure sort(var a:arr;l:integer); var   i,j,t:integer; begin   for i:=1 to l-1 do     for j:=i to l do       if a[j]<a[i] then begin         t:=a[j];         a[j]:=a[i];         a[i]:=t;       end; end; begin   repeat     write('Количество элементов массива:');     readln(k);   until (k>0) and (k<101);   write('Введите массив:');   for i:=1 to k do     repeat       write('a[',i,']=');       readln(a[i]);     until (a[i]>-11) and (a[i]<11);   print('Оригинальный массив:',a,k);   l:=0;skv:=0.0;   for i:=1 to k do     if a[i]<0 then begin       a[i]:=sqr(a[i]);       skv:=skv+a[i];       l:=l+1;     end else a[i]:=i;   print('Полученный массив:',a,k);   sort(a,k);   print('отсортированный массив:',a,k);   writeln('Среднее арифметическое квадратов отрицательных чисел:',skv/l:0:4);   readln; end.
anovikovsr
Program name;//Имя программы
uses crt;//Запуск программы в консольном режиме НЕОБЯЗАТЕЛЬНО
var 
   a : Integer; 
b : Integer; 
i : Integer; 
c : Integer;
BEGIN //Начало программы 
write('Введите 1 число: ');  readln(a);//Ввод значения первого числа 
c := b-a-1;  write('Введите 2 число: '); 
readln(b);//Ввод значения второго числа 
writeln(a, ' ' , b); //Вывод двух чисел
  writeln(a, ' ' ,a*a,' ' , a*a*a); // Вывод 1 числа, квадрата, куба 
for i := 1 to b-a-1 do  
begin   
a := a + 1;   
writeln(a, ' ',a*a, ' ', a*a*a); // Вывод всех чисел от a до b 
end;         
writeln(b, ' ' ,b*b,' ' , b*b*b);// Вывод 2 числа, квадрата, куба 
ReadKey;  
end. //Конец программы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на Паскале 1. Создать два массива: массив фамилий студентов и массив оценок. Фамилии ввести использую оператор readln, оценки используя Random. Для ввода оценок в диапазоне использовать функцию Random (2, 5Ввод и вывод должен соответствовать примеру ниже: 2 Объявить 4 массива. Создать три массива: массив фамилий студентов и массивы оценок по математике и физике. Фамилии ввести использую оператор readln, оценки используя функцию Random. Для ввода оценок в диапазоне использовать Random (2, 5). Массив, содержащий средние заполнить используя формулу вычисления среднего значения. Ввод и вывод должен соответствовать примеру ниже: 3 Внести дополнение в задачу 2, необходимо вывести количество студентов, имеющих средний >3.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lenalevmax7937
armusaeff
Виктор Попова
klepa-79
lobutev
Savelieva24
Stenenko
romka1210
mustaev
moidela87
srkushaev
Cannabikh
Tatgri
boldyrevanastia22
Михайлович_гергиевич315