?>
чень сросчно! Паскаль #2 Дополните модуль uIntArrayUtils из Приложения А подпрограммами поиска, сортировки, поиска минимального и максимального элементов, а также вставки (удаления) элементов в массив из лабораторной работы «Массивы». #4 Составьте программу для работы с одномерным целочисленным массивом. Программа должна реализовать следующие функции: • добавление элементов в массив; • вывод содержимого массива на экран; • вставка и удаление произвольного элемента; • сортировка несколькими поиск элемента; • замена элемента; • поиск минимально и максимального элементов; • удаление всех дубликатов; • заполнение массива случайными значениями. Для решения задачи используйте модули uIntArrayUtils и uCommandList. Приложение А в пдф файле
Ответы
необходим для подключения заголовочных файлов из стандартной библиотеки C/C++ (в этом случае название заголовочного файла указывается в угловых скобках, например, #include <cstdlib>) или заголовочных файлов сторонних библиотек (в этом случае название указывается в двойных кавычках, например, #include "sqlite3.h").
using namespace std
используется для выбора пространства имён std по-умолчанию. В библиотеках могут быть использованы различные пространства имён, ограничивающие область видимости функций, классов и глобальных переменных. В стандартной библиотеке используется пространство имён std, указывающее на то, что данная конструкция является частью стандартной библиотеки. Если не использовать никакое пространство имён, то даже при подключении заголовочного файла (например применив вызов #include <iostream>), мы не сможем явно использовать элементы этой библиотеки, которые объявлены в пространстве имён std. Т.е. вызов cout << "Привет, мир!" вызовет ошибку, что объект cout не найден. Это происходит потому, что данный объект имеет область видимости только внутри пространства имён std. Но мы можем его вызвать, явно указав, в каком пространстве имён следует искать данный объект. Для этого необходимо перед именем объекта указать имя пространства имён, в котором он находится. Пример:
#include <iostream>
int main()
{
cout <<"Hello!" // Ошибка - не указано пространство имён
std::cout <<"Hello!" // Нет ошибки - вызов объекта из пространства имён std, указанного явным образом
}
как-то так...