nordwokintos4
?>

На Python Самое частое число Дан список. Не изменяя его и не используя дополнительные списки, определите, какое число в этом списке встречается чаще всего. Если таких чисел несколько, выведите любое из них. Входные данные Вводится список чисел. Все числа списка целые, по модулю не превосходят 1000 и находятся на одной строке. Выходные данные Выведите ответ на задачу. Примеры Ввод Вывод 1 1 1 1 2 2 2 3 3 3 1

Информатика

Ответы

porotikova1004

lst = [int(_) for _ in input().split()]

dictionary = dict()

for num in lst:

   if num in dictionary:

       dictionary[num] += 1

   else:

       dictionary[num] = 1

print(max(dictionary.items(), key=lambda x: x[1])[0])

rusvicktor
При форматировании документа в целом могут выполняться следующие операции: - установка параметров страницы (формата печатной страницы): полей страницы, размера бумаги, ориентации листа – книжной или альбомной и др. - разбивка на страницы, разделы; - вставка номеров страниц, колонтитулов, сносок, закладок, примечаний и т.п.; - создание или вставка формул, рисунков, таблиц, видео или звуковых фрагментов; - вставка названий иллюстраций, перекрестных ссылок; - форматирование оглавления, указателей, списков иллюстраций и т.д.
egorstebenev6
Квадратное уравнение имеет вид: ах^2 + bx + c = 0. (1)здесь а, b и с – коэффициенты. сначала надо вычислить дискриминант квадратного уравненияd = (b^2 – 4ac) (2)если d > 0, то квадратное уравнение имеет два корня х1 и х2. обозначим с = корень(d). то есть надо вычислить квадратный корень из d. имеем такие решениях1 = (–b + c)/(2a) и x2 = (–b – c)/(2a). (3)если дискриминант d = 0, то c = 0 и оба корня одинаковы х1 = х2 (хотя в школе обычно говорят, что имеется только одно решение) и вычисляются по формулех1 = х2 = –b/(2a). (4). эта формула следует из формулы (3) при с = d = 0.если дискриминант d меньше нуля, то корень из d вычислить нельзя, с будет мнимым числом. вообще говоря, корни есть (2 штуки), но они будут мнимыми числами. хотя в школе учат, что в этом случае корней нет. так и будем считать, что корней нет.алгоритм решения будет следующий но только здесь дискриминант d обозначен малой буквой d

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На Python Самое частое число Дан список. Не изменяя его и не используя дополнительные списки, определите, какое число в этом списке встречается чаще всего. Если таких чисел несколько, выведите любое из них. Входные данные Вводится список чисел. Все числа списка целые, по модулю не превосходят 1000 и находятся на одной строке. Выходные данные Выведите ответ на задачу. Примеры Ввод Вывод 1 1 1 1 2 2 2 3 3 3 1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

julya847
marinatehnomaster21
euzdenova
allo22-27
mayorovmisc6
POMILEVAVladimirovna269
juliapierrat
Yevgeniya1807
olyafom1234
minaskorolev8
bochkarevazh
Andrei-Shchukin
dimalihachew
Norov
Лебедев972