Лихачев Полина1978
?>

Составить программу для исполнителя "Чертежник", которая нарисует прямоугольник шириной 4 и высотой 2 см

Информатика

Ответы

gubernatorov00

использовать Чертежник

алг

нач

цел ш, в

ш:=4

в:=2

опустить перо

сместиться на вектор (ш,0)

сместиться на вектор (0,-в)

сместиться на вектор (-ш,0)

сместиться на вектор (0,в)

поднять перо

кон

Mikhailovna_Litvinova276
#include <iostream>
using namespace std;
int main()
{
setlocale (0,"");
int n1,n2,n3,p1,p2,p3;
cout<<"введите количество учеников в каждом классе"<<endl;
cout<<"1-";
cin>>n1;
cout<<"2-";
cin>>n2;
cout<<"3-";
cin>>n3;
    p1=n1/2; if (n1%2!=0) p1++;
    p2=n2/2; if (n2%2!=0) p2++;
    p3=n3/2; if (n3%2!=0) p3++;
cout<<"для первого класса - "<<p1<<endl;
cout<<"для второго класса - "<<p2<<endl;
cout<<"для третьего класса - "<<p3<<endl;
return 0;
}
malgoblin2663

Программа:

Pascal:

№1)

var arr: array[1..10] of integer;

begin

 for var i := 1 to 10 do arr[i] := random(100);

 writeln(arr);

end.

№2)

const N = 15;

var arr: array[1..N] of integer;

 i, tmp: integer;

begin

 for i := 1 to 15 do arr[i] := random(100);

 writeln(arr);

 for i:=1 to n div 2 do begin

   tmp := arr[i];

   arr[i] := arr[N - i + 1];

   arr[N - i + 1]:= tmp;

end;

writeln(arr);

end.

№3)

const N = 20;

var

 arr: array[1..N] of integer;

 i, tmp, j: integer;

begin

 for i := 1 to N do readln(arr[i]);

 writeln(arr);

 for i := 1 to N - 1 do

   for j := 1 to N - i do

     if (arr[j] > arr[j+1]) then begin

       tmp := arr[j];

       arr[j] := arr[j+1];

       arr[j+1] := tmp;

     end;

 writeln(arr);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для исполнителя "Чертежник", которая нарисует прямоугольник шириной 4 и высотой 2 см
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

OlgaVasilevna
snabomp
lele4kass
silviya
dima-pashkovec
kia80
Павел_Перелыгин
ftyh6
mrvasilev2012
Negutsa_Kseniya524
Пимкина Сергеевич
НиколаевнаОльга
Alsergus7811
gavrilasmax05
Varagyan1728