mtcover
?>

Написать программу на языке Паскаль для вычисления наибольшего общего делителя двух целых положительных чисел по готовой блок-схеме

Информатика

Ответы

mashuska
*** 1 ***
// PascalABC.NET 3.1, сборка 1267 от 10.07.2016
begin
  var w:='КОМПЬЮТЕР';
  Writeln(w[1:4]);
  Writeln((w.Right(3).Inverse)+w[w.Length]+w[2]);
  Writeln(w[w.Length]+w[2::-1])
end.

Результат
КОМ
РЕТРО
РОК

*** 2 ***
// PascalABC.NET 3.1, сборка 1267 от 10.07.2016
begin
  var w:='КОМПЬЮТЕР';
  var i:=ReadInteger('i=');
  Swap(w[i],w[w.Length]);
  Writeln(w)
end.

Тестовое решение
i= 5
КОМПРЮТЕЬ

*** 3 ***
// PascalABC.NET 3.1, сборка 1267 от 10.07.2016
begin
  var w:='ПАР'; // исходное слово
  var k:=4; // константа сдвига шифра Цезаря
  var a:='';
  for var i:=1 to w.Length do begin
    var p:=Pos(w[i],a);
    if p>0 then w[i]:=a[p+k]
    end;
  Writeln(w)
end.

Результат
УДФ
stmr29
Дано:
Страниц - 3
Строк - 25
Символов в строке - 60
Объём всего - 1125 байт
Формулы:
Нахождение общего количество символов:
Страницы*Строки*Символов в строке=Общее количество символов
Перевод из байт в биты:
байты*8=биты
Вычисление мощности алфавита:
2^b>=A (где A-мощность алфавита, b-количество бит, приходящееся на 1 символ)
Решение:
Вычислим общее количество символов: 
3(страницы)*25(строки)*60(символы)=4500 символов 
Теперь вычислим число бит, выделяемое на хранение 1 символа: 
1125 байт=9000 бит 
9000(бит)/4500(символов)=2 бит 
Нахождение мощности алфавита:
2^2=4 символа
ответ: 4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке Паскаль для вычисления наибольшего общего делителя двух целых положительных чисел по готовой блок-схеме
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

solonataly5
ilds88
Petrakova Ilyushin
Galkin683
Plamia7917
arch5050
iordanekaterina
cosmetic89
Оздоевский
nekarpova
bei07
nord0764
inris088
Iprokopova81
windless-el
▲