M19026789436
?>

PROGRAM Z1; Образец VAR A, H: INTEGER; S: REAL; BEGIN WRITELN (‘ВВЕДИ ОСНОВАНИЕ ТРЕУГОЛЬНИКА’); READLN (A); WRITELN (‘ВВЕДИ ВЫСОТУ ТРЕУГОЛЬНИКА’); READLN (H); S:=A*H/2; WRITE (‘ПЛОЩАДЬ ТРЕУГОЛЬНИКА РАВНА ‘, S); END. Составьте программы, которые позволят решать задачи: 1) Вычислить периметр треугольника Переменные: А, В, С – стороны треугольника (целые числа) P – периметр (целое число) Входные данные Выходные данные 3 4 5 12 2) Вычислить периметр и площадь квадрата Переменные: А - сторона квадрата (целые числа) P – периметр квадрата (целое число) S – площадь квадрата (целое число) Входные данные Выходные данные 3 12 9 3) Вычислить площадь трапеции Переменные: А, В – основания трапеции (целые числа) H – высота трапеции (целое число) S – площадь трапеции (вещественное число) Входные данные Выходные данные 10 7 4 34

Информатика

Ответы

srkushaev
Код#include <iostream>#include <utility>#include <numeric>#include <vector>class Beast {    int trigger;    double aggression;    double rage_aggression;public:    Beast() = default;    Beast(int trigger, double aggression, double range_aggression)    : trigger(trigger), aggression(aggression), rage_aggression(range_aggression)    { }    Beast(const Beast&) = default;    Beast(Beast&&) = default;    Beast& operator=(const Beast&) = default;    Beast& operator=(Beast&&) = default;    [[nodiscard]] double calculate_aggression(unsigned long amount) const {        return amount > trigger ? rage_aggression : aggression;    }    void ReadFrom (std::istream& is) {        is >> aggression >> rage_aggression >> trigger;    }    void WriteTo(std::ostream &os) const {        os << aggression << " " << rage_aggression << " " << trigger;    }};std::istream& operator >>(std::istream &is, Beast &cls) {    cls.ReadFrom(is);    return is;}std::ostream& operator <<(std::ostream &os, const Beast &cls) {    cls.WriteTo(os);    return os;}class Cage {    double durability;    std::vector<Beast> container;public:    explicit Cage(double durability, std::vector<Beast> container)    : durability(durability), container(std::move(container))    { }    Cage(const Cage&) = default;    Cage(Cage&&) = default;    Cage& operator=(const Cage&) = default;    Cage& operator=(Cage&&) = default;    [[nodiscard]] double calculate_aggressive() const {        auto amount = container.size();        if (amount == 0) return 0;        return std::accumulate(container.begin(), container.end(), 0.0,        [amount](double total_aggressive, const Beast & beast){            return total_aggressive + beast.calculate_aggression(amount);        });    }    [[nodiscard]] bool is_it_normal() const {        auto aggressive = calculate_aggressive();        return aggressive <= durability;    }    [[nodiscard]] int get_capacity() const {        return container.size();    }    [[nodiscard]] double get_durability() const {        return durability;    }};template <typename T>void subsetsUtil(std::vector<T>& A, std::vector<std::vector<T> >& res,                 std::vector<T>& subset, int index){    res.push_back(subset);    for (int i = index; i < A.size(); i++) {        // include the A[i] in subset.        subset.push_back(A[i]);        // move onto the next element.        subsetsUtil(A, res, subset, i + 1);        // exclude the A[i] from subset and triggers        // backtracking.        subset.pop_back();    }}template <typename T>std::vector<std::vector<T>> P(std::vector<T>& A){    std::vector<T> subset;    std::vector<std::vector<T>> res;    int index = 0;    subsetsUtil(A, res, subset, index);    return res;}int main () {    int n, s;    Beast noname{};    std::vector<Beast> set_of_beasts;    std::cin >> n >> s;    for (auto i = 0; i < n; ++i) {        std::cin >> noname;        set_of_beasts.push_back(noname);    }    auto selections = P(set_of_beasts);    std::vector<Cage> variants;    std::transform(selections.begin(), selections.end(), std::back_inserter(variants), [s](std::vector<Beast> &selection){        return Cage(s, selection);    });    std::vector<Cage> true_variants;    std::copy_if(variants.begin(), variants.end(), std::back_inserter(true_variants), [](Cage& x) {return x.is_it_normal();});    auto the_best_of_the_best_variant = *std::max_element(true_variants.begin(), true_variants.end(), [](Cage & s1, Cage & s2){        return s1.get_capacity() < s2.get_capacity();    });    std::cout << the_best_of_the_best_variant.get_capacity();    return 0;}
У Арсения есть n зверьков. Каждый из них обладает характером, поэтому, если в клетке, где находится
У Арсения есть n зверьков. Каждый из них обладает характером, поэтому, если в клетке, где находится
Valerevna-Vardan

#include <iostream>

using namespace ::std;

int main()

{

   setlocale(LC_CTYPE , "rus");

   

   int n, i, j = 0, k = 0;

   double s = 0;

   cout << "Введите количество элементов: \n";

   cin >> n;

   float x;

   float *massiv = new float[n];

   if (!massiv)

   {

       cout << "Сбой программы!\n";

       system("pause");

        return 0;

   }

   cout << "Введите массив с " << ' ' << n << ' ' << "элементов\n";

   for (i = 0; i < n; i++)

       cin >> *(massiv + i);

   cout << "Заданный массив: " << endl;

   for (int i = 0; i < n; i++)

       

       cout << *(massiv + i) << ' ' << endl;

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i]>0)

           k++;

   }

   cout << " Количество положительных элементов = " << k << '\n';

 

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i] == 0) {

           j = massiv[i];

           x = i;

       }

   }

 

   for (i = x; i<n; i++)

       s += massiv[i];

 

   cout << "Сумма =" << s;

   float *massiv2 = new float[n];

   if (!massiv2)

   {

       cout << "Сбой программы !\n";

       system("pause");

       return 0;

   }

   for (i = 0; i < n; i++)

       if (massiv[i] <= 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

 

   for (i = 0; i < n; i++)

       if (fabs(massiv[i]) > 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

   cout << endl << "Отсортированный массив: " << endl;

   for (int j = 0; j < n; j++)

       cout << '\n' << massiv2[j] << ' ';

 

   delete[] massiv;

   delete[] massiv2;

   system("pause");

   return 0;

}

В работо не сомневайся.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

PROGRAM Z1; Образец VAR A, H: INTEGER; S: REAL; BEGIN WRITELN (‘ВВЕДИ ОСНОВАНИЕ ТРЕУГОЛЬНИКА’); READLN (A); WRITELN (‘ВВЕДИ ВЫСОТУ ТРЕУГОЛЬНИКА’); READLN (H); S:=A*H/2; WRITE (‘ПЛОЩАДЬ ТРЕУГОЛЬНИКА РАВНА ‘, S); END. Составьте программы, которые позволят решать задачи: 1) Вычислить периметр треугольника Переменные: А, В, С – стороны треугольника (целые числа) P – периметр (целое число) Входные данные Выходные данные 3 4 5 12 2) Вычислить периметр и площадь квадрата Переменные: А - сторона квадрата (целые числа) P – периметр квадрата (целое число) S – площадь квадрата (целое число) Входные данные Выходные данные 3 12 9 3) Вычислить площадь трапеции Переменные: А, В – основания трапеции (целые числа) H – высота трапеции (целое число) S – площадь трапеции (вещественное число) Входные данные Выходные данные 10 7 4 34
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lavr74
supply1590
Inforealto
nestruev
argo951385
Galkin683
grekova5
zabrodin
kchapurina591
tatianaavoronina66
zotcet7
Татьяна-Мария
Tamara
tarasowamash4
andr77716