potapin
?>

В банк положили 5000 р. под 6 % годовых, проценты начинаются каждый месяц к сумме на счёте. Написать программу, которая подсчитает сумму на счёте через N месяцев. (Pascal) ​

Информатика

Ответы

dg9792794674
Var
  i,d,n,k:integer;
begin
  Write('Введите трехзначное натуральное число: ');
  Read(n);
  k:=0;
  for i:=1 to 3 do begin
    d:=n mod 10;
    if d mod 3=0 then begin
      Inc(k);
      Write(d,' ')
      end;
    n:=n div 10
    end;
  if k>0 then Write('- цифры, кратные трем')
  else Write('Таких цифр нет')
end.

Примеры
Введите трехзначное натуральное число: 569
9 6 - цифры, кратные трем

Введите трехзначное натуральное число: 184
Таких цифр нет

Замечание: в программе считается, что цифра 0 также кратна трем (как и всем другим числам), поскольку остаток от деления от нуля на 3 равен 0.
Если это не так, то замените условие
d mod 3 = 0
на
(d mod 3 = 0) and (d>0)
Semenova
Сумма натуральных чисел из промежутка от 1 до 100, которые делятся на 17 и сумма цифр, которых не превышает 7. Можно перебором} var i,s:integer; begin s:=0; for i:=1 to 100 do if (i mod 17=0) and (i div 10 + i mod 10<7) then s:=s+i; writeln(s); end. {результат 51} { Можно оптимизировать в цикле изменив for i:=1 to 100 do на for i:=17 to 100 do} {2 вариантө оптимальнее - перебираем только числа кратные 17] var i,s:integer; begin s:=0; i:=17; while i<=100 do begin if (i div 10 + i mod 10<7) then s:=s+i; i:=i+17; end; writeln(s); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

В банк положили 5000 р. под 6 % годовых, проценты начинаются каждый месяц к сумме на счёте. Написать программу, которая подсчитает сумму на счёте через N месяцев. (Pascal) ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

d2002
antoha512
Sergeevich-irina
.Е.-Прокопьева
Конычева-музей&quot;260
pavlovm8316
Александрович_Викторовна
Алина1564
владимировнаКлютко
silviya
Kochinev4
tashovairina
bronco-s
sbn07373
gumirovane2294
▲