d111180
?>

Напишите программу которая сортирует массив из N элементов по возрастанию методом пузырька и считает при этом количество произведённых перестановок. Протестировать программу на следующих исходных данных :А) 2 5 1 6 4 10 4 2 Б) 1 2 5 6 -4 0 11 12 В) 12 10 6 4 2 1 0​

Информатика

Ответы

Абумислимовна_кооператив585
На c++

#include <iostream>#include <ctime>int main(){ using namespace std; const int ArSize = 10; int ar[ArSize]; int s_less = 0, s_more = 0; int k_less = 0, k_more = 0; srand(time(0)); for (int i = 0; i < ArSize; i++) ar[i] = rand() % 101; for (int i = 0; i < ArSize; i++) cout << ar[i] << ' ';
for (int i = 0; i < ArSize; i++) { if (ar[i] < 50) { s_less = s_less + ar[i]; k_less = k_less + 1; } if (ar[i] > 50) { s_more = s_more + ar[i]; k_more = k_more + 1; } } cout << "\nAverage of numbers less than 50: " << (double)s_less / k_less << endl; cout << "Average of numbers more than 50: " << (double)s_more / k_more << endl; return 0;}
antoska391
Uses crt,graphABC;
var a,m,n,j,i,x1,y1,x2,y2,x3,y3,x4,y4,kg,kv,p:integer;
    k:real;
    
procedure kvadrat;//рисование 1 квадрата
begin
setpencolor(clBlue);
moveto(x1,y1);
lineto(x2,y2);
lineto(x3,y3);
lineto(x4,y4);
lineto(x1,y1);
end;
 
begin
hidecursor;
repeat
write('Сторона квадрата от 20 до 100 a=');
read(a);
until a in [20..100];
repeat
writeln('Введите 2 числа для определения соотношени m<n:');
read(m,n);
until m<n;
clearwindow;
k:=m/n;//отношение
kg:=windowwidth div a+1; //кол. кв. по горизонтали
kv:=windowheight div a+1; //по вертикали
for j:=1 to kg do
for p:=1 to kv do
 begin
  for i:=1 to 50 do //рисуем 50 вложенных квадратов в 1 месте
   begin
    kvadrat;
    x1:=trunc(x1+(x2-x1)*k); y1:=trunc(y1+(y2-y1)*k);
    x2:=trunc(x2+(x3-x2)*k); y2:=trunc(y2+(y3-y2)*k);
    x3:=trunc(x3+(x4-x3)*k); y3:=trunc(y3+(y4-y3)*k);
    x4:=trunc(x4+(x1-x4)*k); y4:=trunc(y4+(y1-y4)*k);
   end;
x1:=a*(j-1); y1:=a*(p-1); //на новое место
x2:=a*j; y2:=a*(p-1);
x3:=a*j; y3:=a*p;
x4:=a*(j-1); y4:=a*p;
end;
 
 
end.

Втетради нарисовать орнамент из разноцветных прямоугольников, ромбов, квадратов, подготовить програм

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу которая сортирует массив из N элементов по возрастанию методом пузырька и считает при этом количество произведённых перестановок. Протестировать программу на следующих исходных данных :А) 2 5 1 6 4 10 4 2 Б) 1 2 5 6 -4 0 11 12 В) 12 10 6 4 2 1 0​
Ваше имя (никнейм)*
Email*
Комментарий*
▲