parolmm
?>

1)Чему будет равно значение переменной x после выполнения следующих команд?x := 10;for i := 10 downto 2 dox := x – i;2)Необходимо было написать программу, которая позволяет найти наименьшее число, большее 500, кратное 17 и вывести его на экран.Программист торопился и написал программу с ошибками. Укажите строки, в которых допущены ошибки.Var x: integer; Begin x := 500; Repeat x := x – 1; Until x mod 17 <> 0; Writeln (x); End.

Информатика

Ответы

Viktorovna1012

1)   -44

2)  

x := x – 1;

Until x mod 17 <> 0; 

Объяснение:

1)

x = 10

для i от 10 до 2 выполнить x = x - i

i = 10       x = 10 - 10 = 0

i = 9        x = 0 - 9 = -9

i = 8        x = -9 - 8 = -17

i = 7        x = -17 - 7 = -24

i = 6        x = -24 - 6 = -30

i = 5        x = -30 - 5 = -35

i = 4        x = -35 - 4 = -39

i = 3        x = -39 - 3 = -42

i = 2        x = -42 - 2 = -44

2)

Var x: integer;

Begin

x := 500;

Repeat

x := x + 1;

Until x mod 17 = 0;

Writeln (x);

End.

x := x - 1; - необходимо найти число большее 500, поэтому x надо увеличивать на 1, а не уменьшать

Until x mod 17 <> 0; - цикл с постусловием работает пока условие ложно, поэтому чтобы найти число кратное 17 условие должно иметь вид x mod 17 = 0

karasev17764
Цикл с предусловием это такой цикл, в котором условие проверяется перед выполнением тела цикла.
А цикл с постусловием - на оборот, он сначала выполнит, а потом проверит условие и если условие true, то цикл завершится.

Цикл с постусловием, можно использовать в таких ситуациях, когда надо что-то сделать и если чего-то не хватает, то сделать еще раз. Напрмер отправить письмо на email, а если не отправилось, то повторить еще 3 раза. Сначала выполнится тело цикла, в котором находятся функции отправки письма и если отправка удачная, то сообщаем until() true. Иначе тело выполнится еще и еще и еще кучу раз, если мы не задали счетчик в теле цикла, как вариант...

Цикл с предусловием можно использовать, если надо проверять какое-то значение ПЕРЕД выполнением тела цикла и тебе не важно, должно ли оно хоть раз выполниться. Например запросить пароль у пользователя. Но если пользователь уже ввёл пароль, то зачем его запрашивать? Тут можно было бы использовать while
gorushko-tabak3

Для определения информационного объема сообщения воспользуемся формулой: I = K * i,  где K - количество символов, i - вес одного символа.

1)  1024 стра­ни­цы, на одной стра­ни­це по­ме­ща­ет­ся 64 стро­ки, а в стро­ке по­ме­ща­ет­ся 64 сим­во­ла. Каж­дый сим­вол в ко­ди­ров­ке КОИ-8 за­ни­ма­ет 8 бит па­мя­ти.

i = 8 бит

K = 1024 * 64 * 64 = 4194304 символов,

I = 4194304 * 8 = 33554432 бит = 4194304 байт = 4096  Кбайт = 4 Мбайт

2) 512 стра­ниц, на одной стра­ни­це в сред­нем по­ме­ща­ет­ся 64 стро­ки, а в стро­ке 64 сим­во­ла. (Каж­дый сим­вол в ко­ди­ров­ке Unicode за­ни­ма­ет 16 бит па­мя­ти.)

i = 16 бит

K = 512 * 64 * 64 = 2097152 символов,

I = 2097152 * 16 = 33554432 бит = 4194304 байт = 4096 Кбайт = 4 Мбайт

*8 бит = 1 байт

1024 байт = 1 Кбайт

1024 Кбайт = 1 Мбайт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)Чему будет равно значение переменной x после выполнения следующих команд?x := 10;for i := 10 downto 2 dox := x – i;2)Необходимо было написать программу, которая позволяет найти наименьшее число, большее 500, кратное 17 и вывести его на экран.Программист торопился и написал программу с ошибками. Укажите строки, в которых допущены ошибки.Var x: integer; Begin x := 500; Repeat x := x – 1; Until x mod 17 <> 0; Writeln (x); End.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bhg50
Игоревна Худанов1150
Gennadevna-Darya1216
Бабур
mmurzina
alexey
Rinatum1978
Геннадьевна Вета560
antonkovalev89
most315
ibswoklol1362
sensenagon50
rozhkova
Yevgenevich
maksmi