tofilev
?>

Написать в паскале 1 Вывести на экран все двузначные числа в строку через пробел 2 Напишите программу, которая 7 раз выводит на экран "Черненко Семён" 3 Напишите программу, которая вычисляет сумму всех четных чисел в диапазоне от 1 до n.

Информатика

Ответы

sakh2010kprf7

Задание 1:

begin for var x := 10 to 99 do print(x); end.

Задание 2:

begin loop 7 do println('Черненко Семён') end.

Задание 3:

begin (1..ReadInteger('n:')).Where(x->x.isEven).Sum.Print end.

Пример работы:


Написать в паскале 1 Вывести на экран все двузначные числа в строку через пробел 2 Напишите программ
Руслан1360
#include <iostream>
using namespace std;
int main()
{
setlocale(0,""); // это что бы на русском было
cout<<" Сижу за решеткой в темнице сырой."<<endl;
cout<<"Вскормленный в неволе орел молодой,"<<endl;
cout<<"Мой грустный товарищ, махая крылом,"<<endl;
cout<<"Кровавую пищу клюет под окном,"<<endl;
cout<<"Клюет, и бросает, и смотрит в окно,"<<endl;
cout<<"Как будто со мною задумал одно;"<<endl;
cout<<"Зовет меня взглядом и криком своим"<<endl;
cout<<"И вымолвить хочет: «Давай улетим!"<<endl;
cout<<"Мы вольные птицы; пора, брат, пора!"<<endl;
cout<<"Туда, где за тучей белеет гора,"<<endl;
cout<<"Туда, где синеют морские края,"<<endl;
cout<<"Туда, где гуляем лишь ветер... да я!..»"<<endl;
return 0;
}
zhandarmova

в 3 раза

Объяснение:

Т.к. изображение одно и тоже, то количество точек в них одинаковое (K).

i = 24 бит для p1.bmp

2^i = 256

i = 8 бит для  p2.bmp

Для p1.bmp V = 24K

Для p2.bmp  V = 8K

24 / 8 = 3

В 3 раза будет меньше информационный объём файла p2.bmp.

V = K * i, где  

V - информационный объём изображения (размер файла, содержащего изображение)

K - количество точек (пикселей )

i - глубина цвета (число бит, используемых для записи цвета одного пикселя)

N = 2^i, где  

N - количество цветов в палитре

i - глубина цвета (число бит, используемых для записи цвета одного пикселя)

^ - знак степени

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать в паскале 1 Вывести на экран все двузначные числа в строку через пробел 2 Напишите программу, которая 7 раз выводит на экран "Черненко Семён" 3 Напишите программу, которая вычисляет сумму всех четных чисел в диапазоне от 1 до n.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

YelenaZOLTANOVICh105
varvv15
maksteks
santechma
ivshzam
михаил
partners
Varezka86179
karkh267
Маргарита1091
iordanekaterina
allo22-27
sashakrav
Rizhov Alekyan325
namik120939