Вадимовна
?>

Напишите программу, суммирующую 4 числа и увеличивающую сумму в два раза (на языке паскаль)

Информатика

Ответы

АнастасияAndrey
Cистемная плата - основа любого компьютера, будь то сервер, десктоп, ноутбук, планшет или какой-то встраиваемый аппарат. Как же производятся эти важнейшие компоненты современной вычислительной техники?
Подавляющее большинство материнских плат для компьютеров во всём мире производится на острове Тайвань и в материковом Китае, там же в большинстве случаев разрабатывается и конструкция этих плат. Более того, даже эталонные конструкции ("референсный дизайн") системных плат чаще всего создаются не в американских офисах, а всё там же, на Тайване, в непосредственной близости от фабрик, где эти платы будут выпускаться. В отличие, кстати, от видеокарт, конструированием которых занимаются исключительно штатные инженеры AMD и NVIDIA.
После утверждения эталонной конструкции системной платы, которую разработчики наборов системной логики рассылают своим партнёрам, в компаниях-производителях "материнок" начинается работа по созданию собственных моделей. Как правило, на базе чипсетов одного семейства или даже одного и того же набора микросхем проектируется три варианта плат: недорогой, для компьютеров среднего класса и высокопроизводительный для энтузиастов.
Vika-simonenko
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=MatrRandom(6,5,-50,50); a.Println(4); Writeln;
  var res:=new int64[6];
  for var i:=0 to 5 do
    if i.IsEven then
      res[i]:=a.Row(i).Aggregate(int64(1),(x,y)->x*y)
    else
      res[i]:=a.Row(i).Sum;
  Writeln('Результаты:'); res.Println(NewLine)
end.

Пример
 -32  22  12   8 -38
  45  22 -12  26  -2
 -46  12  19  42  -1
  19   5  29 -41 -41
  10 -23   2 -19  10
  -4  22  15  34  34

Результаты:
2568192
79
440496
-29
87400
101

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, суммирующую 4 числа и увеличивающую сумму в два раза (на языке паскаль)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

saniopt
Vladstreletskiy
samirmajbubi
ВостриковаСтародубцева1980
videofanovitch
pk199888
marinaled8187
shymilin19951783
mvolkov8
НосовЖелиховская
Андрей628
v89167233402
elenakarpova709
krikatiy
Mamikin
▲