?>
3. Пусть элементами равностороннего треугольника являются радиус описанной окружности (R); радиус вписанной окружности (r); сторона (с Написать программу, которая по соответствующей введенной букве (прописной или строчной) , рисует определенным цветом и надписывает соответствующий параметр. Предусмотреть критический случай
Ответы
#include <iostream>
#include <stack>
#include <string>
using namespace std;
int main()
{
setlocale(0, ""); // кириллица
stack <int> st;
cout << "ВВОД СТЕКА\n"
<< "Введите '0' для остановки\n";
while (true)
{
int c;
cin >> c;
if (c == 0)
{
break;
}
if (c < 0)
{
c = -1 * c;
}
st.push(c);
}
cout << "ВЫВОД СТЕКА\n";
while ( !( st.empty() ) )
{
cout << st.top() << '\n';
st.pop();
}
return 0;
}