akuznecov8989
?>

Дан массив из n элементов. Необходимо найти количество элементов массива, значения которых не отрицательны и меньше заданного числа A. Формат входных данных: С клавиатуры вводится натуральное число n (n≤100 На следующей строке через пробел вводятся n элементов массива. Все числа по модулю не превосходят 100. В последней строке вводится единственное число A (0≤A≤100). Формат выходных данных: В качестве ответа выведите единственное число — количество элементов, удовлетворяющих условию. входные данные: 5 1 2 3 4 5 3 выходные данные: 2

Информатика

Ответы

mariya
begin var ar := ReadArrInteger(ReadInteger); var A := ReadInteger; Println(ar.Count(x -> x in 0..A-1)); end.

Пример работы:


Дан массив из n элементов. Необходимо найти количество элементов массива, значения которых не отрица
Дан массив из n элементов. Необходимо найти количество элементов массива, значения которых не отрица
volkovaoksana19806037
Program p1;
var k,t:integer;
begin
write('кг = ');
readln(k);
t:=k div 1000;
writeln('В ',k,' кг полных тонн ',t);
end.

Пример:
кг = 54937
В 54937 кг полных тонн 54

program p2;
var a,b,k:integer;
begin
a:=543;
b:=130;
k:=a div b;
writeln('Количество квадратов = ',k);
end.

Результат:
Количество квадратов = 4

program p3;
var a,b:integer;
begin
write('Введите четырехзначное число: ');
readln(a);
b:=9*10000+a;
writeln('Полученное число = ',b);
end.

Пример:
Введите четырехзначное число: 4937
Полученное число = 94937

program p4;
var a,b:integer;
begin
write('Введите трехзначное число: ');
readln(a);
b:=(a mod 100)*10 + a div 100;
writeln('Полученное число = ',b);
end.

Пример:
Введите трехзначное число: 437
Полученное число = 374

program p5;
var v1,v2,v3,t1,t2,t3,s:real;
begin
write('v1, t1: ');
readln(v1,t1);
write('v2, t2: ');
readln(v2,t2);
write('v3, t3: ');
readln(v3,t3);
s:=v1*t1+v2*t2+v3*t3;
writeln('Пройденный путь = ',s:5:2, ' км ');
end.

Пример:
v1, t1: 5 2
v2, t2: 3 0.5
v3, t3: 4 1.5
Пройденный путь = 17.50 км
S.V. Zhoraevna1677
На C++ #include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;int main()
{
   srand(time(0));
   int counter = 0;
   int growth;   for(int i = 0; i < 50; i++)
   {
      if((growth = rand() % 151 + 150) >= 170)
      {
         counter++;
      }
      cout << growth << ' ';
   }
   cout << endl << endl;   cout << counter << " pupil";
   cout << (counter != 1 ? "s" : "") << endl; // Если будет только 1 ученик,
                                             //то больше ничего не печатать
                                             //иначе - допечатать букву "s"   cin.get();
   return 0;

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив из n элементов. Необходимо найти количество элементов массива, значения которых не отрицательны и меньше заданного числа A. Формат входных данных: С клавиатуры вводится натуральное число n (n≤100 На следующей строке через пробел вводятся n элементов массива. Все числа по модулю не превосходят 100. В последней строке вводится единственное число A (0≤A≤100). Формат выходных данных: В качестве ответа выведите единственное число — количество элементов, удовлетворяющих условию. входные данные: 5 1 2 3 4 5 3 выходные данные: 2
Ваше имя (никнейм)*
Email*
Комментарий*