radatailless
?>

Решите тест кому не сложно Выберете номер правильно ответа 1. Для выполнения операций с целочисленными данными в языке Паскаль используют обозначение 1) real 2) integer 3) char 4) boolean 2. Для выполнения операций с логическими данными в языке Паскаль используют обозначение 1) real 2) integer 3) char 4) boolean 3. Обозначение переменной а:=56/7+2 в языке Паскаль 1) real 2) integer 3) char 4) boolean 4. Обозначение переменной а:=7+2 в языке Паскаль 1) real 2) integer 3) сhаr 4) boolean 5. После выполнения программы, записанной на языке Паскаль program prim; var s: integer; begin s:=15; write (‘s=’, s) end. на экран будет выведено 1) s:=15 2) s=15 3) ‘s=’15 4) s= 15 6. После выполнения программы, записанной на языке Паскаль program prim; var s: real; begin s:=15; write (‘s=’, s:3:0) end. на экран будет выведено 1) s:= 15 2) s=15 3)’s=’15 4) s= 15 7. Входной поток, определенный оператором ввода readln (x, y, z) целочисленных значений переменных х, у и вещественной переменной z 1) 1 2 5 4.7 2) 1, 2, 5, 4.7 3) 12347 4) 1. 2. 3. 4.7 8. Входной поток, определенный оператором ввода readln (x, y, z) целых значений переменных х, у и вещественной переменной z 1) 1 2 5 4. 7 2) 1, 2, 5, 4.7 3) 1234.7 4) 1 2 З 4.7 9. Языковые конструкции, с которых в программах записываются действия, выполняемые над данными в процессе решения задачи 1) переменные 2) стили программирования 3) имена 4) операторы 10. Оператор вывода, который используется для перехода к новой строке 1) write 2) read 3) writeln 4) readln 11. Запишите, как на языках программирования называют запись алгоритмов. 12. Запишите, как на языках программирования называют число, определяющее количество позиций на экране, которые занимает выводимая величина. 13. Укажите операторы, используемые для ввода данных в Паскале. 14. Укажите операторы, используемые для вывода данных в Паскале. 15. Расположите строки так, чтобы получилась программа Symma, рассчитывающая по двум введённым с клавиатуры числам их сумму. В ответе запишите правильную последовательность номеров. 16. Расположите строки так, чтобы получилась программа Gipotenuza, рассчитывающая по двум введённым с клавиатуры катетам квадрат гипотенузы прямоугольного треугольника. 17. Дан фрагмент программы: s:=114.34384 writeln (s:6:2); После его выполнения на экран будет выведено: 1. 114.34384 2. s:= 114.34 3. s:=114.34384 4. 114.34 18. Переменной a присвоено значение 5. Установите соответствие: 1. Write(‘a’) 2. Write(a) 3. Write(‘a=’, a) 1. 5 2. a 3. a=5 19. Что будет выведено на экран после выполнения следующей программы: var a, s: real; begin a: = 3; s: = a*a; writeln('s=', s:3:1) end. 1. s:=9 2. s=9 3. 9 4. s=9.0 20. Целочисленным переменным a, b, c надо присвоить соответственно значения 1, 2 и 3. Какой оператор ввода соответствует входному потоку 2 1 3? 1. readln (a, b, c) 2. read (a, b, c) 3. read (b, a, c) 4. read b, a, c

Информатика

Ответы

Бирюков Карпова1379
// тестировалось на C#.Net Framework 4.5
using System;

class Program
{
    static void Main()
    {
        int x1 = 2, y1 = 1;
        int x2 = 6, y2 = 5;
        int x3 = 10, y3 = 1;

        var a = Distance(x2, y2, x3, y3);
        var b = Distance(x1, y1, x3, y3);
        var c = Distance(x2, y2, x1, y1);

       
        Console.WriteLine("S = {0}", Square(a, b, c));
        Console.ReadKey();
    }

    //растояние между точками
    static double Distance(int x1, int y1, int x2, int y2)
    {
        return Math.Sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1));
    }

    //формула герона
    static double Square(double a, double b, double c)
    {
        var p = (a + b + c) / 2;
        return Math.Sqrt(p * (p - a) * (p - b) * (p - c));
    }

    // теорема косинусов
    static double Angle(double a, double b, double c)
    {
        return Math.Acos((b * b + c * c - a * a) / (2 * b * c));
    }

    static bool IsAcuteAngel(double alpha)
    {
        return alpha < Math.PI / 2;
    }
}
romashka17-90
Var
a:array[1..100,1..100] of integer;
c:array[1..20,1..20] of real;
b:array[1..20,1..20] of real;
i,j,n,k:integer;
t:real;
r:integer;
begin
randomize;
t:=0;
Writeln('Введите порядок матрицы: ');
readln(n);
for i:=1 to n do
for j:=1 to n do
begin
a[i, j] := random(10); 
end;
for i:=1 to n do
for j:=1 to n do
begin
b[i,j]:=1/i+j-1;
end;
for i:=1 to n do
for j:=1 to n do
begin
for k:=1 to n do
begin
t :=t+a[i,k]*b[k, j];
end;
c[i,j]:=t;
t:=0;
end;
for i:=1 to n do
begin
for j:=1 to n do
begin
write(' ',c[i,j]:2:2);
end;
Writeln;
end;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите тест кому не сложно Выберете номер правильно ответа 1. Для выполнения операций с целочисленными данными в языке Паскаль используют обозначение 1) real 2) integer 3) char 4) boolean 2. Для выполнения операций с логическими данными в языке Паскаль используют обозначение 1) real 2) integer 3) char 4) boolean 3. Обозначение переменной а:=56/7+2 в языке Паскаль 1) real 2) integer 3) char 4) boolean 4. Обозначение переменной а:=7+2 в языке Паскаль 1) real 2) integer 3) сhаr 4) boolean 5. После выполнения программы, записанной на языке Паскаль program prim; var s: integer; begin s:=15; write (‘s=’, s) end. на экран будет выведено 1) s:=15 2) s=15 3) ‘s=’15 4) s= 15 6. После выполнения программы, записанной на языке Паскаль program prim; var s: real; begin s:=15; write (‘s=’, s:3:0) end. на экран будет выведено 1) s:= 15 2) s=15 3)’s=’15 4) s= 15 7. Входной поток, определенный оператором ввода readln (x, y, z) целочисленных значений переменных х, у и вещественной переменной z 1) 1 2 5 4.7 2) 1, 2, 5, 4.7 3) 12347 4) 1. 2. 3. 4.7 8. Входной поток, определенный оператором ввода readln (x, y, z) целых значений переменных х, у и вещественной переменной z 1) 1 2 5 4. 7 2) 1, 2, 5, 4.7 3) 1234.7 4) 1 2 З 4.7 9. Языковые конструкции, с которых в программах записываются действия, выполняемые над данными в процессе решения задачи 1) переменные 2) стили программирования 3) имена 4) операторы 10. Оператор вывода, который используется для перехода к новой строке 1) write 2) read 3) writeln 4) readln 11. Запишите, как на языках программирования называют запись алгоритмов. 12. Запишите, как на языках программирования называют число, определяющее количество позиций на экране, которые занимает выводимая величина. 13. Укажите операторы, используемые для ввода данных в Паскале. 14. Укажите операторы, используемые для вывода данных в Паскале. 15. Расположите строки так, чтобы получилась программа Symma, рассчитывающая по двум введённым с клавиатуры числам их сумму. В ответе запишите правильную последовательность номеров. 16. Расположите строки так, чтобы получилась программа Gipotenuza, рассчитывающая по двум введённым с клавиатуры катетам квадрат гипотенузы прямоугольного треугольника. 17. Дан фрагмент программы: s:=114.34384 writeln (s:6:2); После его выполнения на экран будет выведено: 1. 114.34384 2. s:= 114.34 3. s:=114.34384 4. 114.34 18. Переменной a присвоено значение 5. Установите соответствие: 1. Write(‘a’) 2. Write(a) 3. Write(‘a=’, a) 1. 5 2. a 3. a=5 19. Что будет выведено на экран после выполнения следующей программы: var a, s: real; begin a: = 3; s: = a*a; writeln('s=', s:3:1) end. 1. s:=9 2. s=9 3. 9 4. s=9.0 20. Целочисленным переменным a, b, c надо присвоить соответственно значения 1, 2 и 3. Какой оператор ввода соответствует входному потоку 2 1 3? 1. readln (a, b, c) 2. read (a, b, c) 3. read (b, a, c) 4. read b, a, c
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Voronov434
elenarumack
elenaftdv7
Yelizaveta1848
Семеновна-Павел
Что такое анимация сор 5 класс​
Burov1446
Shevchenko
Федоровна-Васильева
Powerbasses5521
Melnik Kaveshnikova1746
nnbeyo
webotryvclub21
valerii-borisovich550
kep92
Екатерина655