ainred
?>

Паскаль ! 1) Используя процедуру, создайте из четных символов строки st1 строку str2 и из нечетных символов - строку str3. 2) Составить программу, подпрограмма которой выведет на экран отсортированный массив по следующему принципу: сначала отрицательные значения, затем нули, последним положительные значения массива.

Информатика

Ответы

Mukhina1811
1. изображение имеет размеры 1200*1024 пиксель, и нарисовано в два цвета: черный и белый. определите размер файла.

1200 * 1024 * 1 бит = 1228800 бит
1228800 бит /8 бит в байте / 1024 байт в килобайте = 150 килобайт

2. рисунок имеет размеры 1920*1080 пиксель, нарисован с палитрой 16 777 216. определите размер файла.
16 777 216 = 2^24 то есть 24 бит. 24 / 8бит = 3 байта на одну точку.
1920*1080*3 = 6220800 байт = 6075 кб

3.для хранения растрового изображения размером 1024*512 пиксель отвели 256 кба памяти. каково максимально возможное число цветов в палитре изображения?

256 кб = 262144 байт

262144 / 1024*512 = 0,5 байта = 4 бита
в четырех битах можно уложить 2^4 = 16 цветов.
Абдулганиева Сергей
//Pascal
//1)
var
  A: array[1..5, 1..8] of integer;
  i, j: byte;
  sumR, sumC: integer;
begin
  randomize;
  writeln('Исходный массив':28);
  for i := 1 to 5 do
  begin
    for j := 1 to 8 do
    begin
      A[i, j] := random(61)-30;
      write(A[i,j]:5);
      if i = 3 then sumR := sumR + A[i, j];
      if j = 5 then sumC := sumC + A[i, j];
    end;
  writeln;
  end;
  writeln('Сумма элементов 5 столбца = ', sumC);
  writeln('Сумма элементов 3 строки = ', sumR);
end.

//2)
var
  A: array[1..5, 1..8] of integer;
  i, j: byte;
  sumA, sumB, countV, countG: integer;
begin
  randomize;
  writeln('Исходный массив':28);
  for i := 1 to 5 do
  begin
    for j := 1 to 8 do
    begin
      A[i, j] := random(300)-150;
      write(A[i,j]:5);
      if ((i = 5) and (A[i, j] < 0)) then sumA := sumA + A[i, j];
      if ((j = 4) and (A[i, j] < 100)) then sumB := sumB + A[i, j];
      if ((i = 4) and (A[i, j] < 5)) then countV := countV + 1;
      if ((j = 2) and (A[i, j] > 15)) then countG := countG + 1;
    end;
  writeln;
  end;
  writeln('Сумма отрицательных 5 строки = ', sumA);
  writeln('Сумма меньших 100 4-ого столбца = ', sumB);
  writeln('Количество меньших 5 4-ой строки = ', countV);
  writeln('Количество ненулевых, больших 15 2-ого столбца = ', countG);
end.

1.дан двумерный массив.определить: а) сумму всех элементов третьей строки массива; б) сумму всех эле
1.дан двумерный массив.определить: а) сумму всех элементов третьей строки массива; б) сумму всех эле

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль ! 1) Используя процедуру, создайте из четных символов строки st1 строку str2 и из нечетных символов - строку str3. 2) Составить программу, подпрограмма которой выведет на экран отсортированный массив по следующему принципу: сначала отрицательные значения, затем нули, последним положительные значения массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

arturo95
Камочкин
nikitamihailov22095010
energycomplect5914
Reznikova1075
orange-salon-job77
Рогова Ольга1156
tershova
Yeroshkina411
Малыхин Валерьевна621
sky-elena712558
sorokinae
samirmajbubi
NikolayGoncharov
antilopa001