verich
?>

решить задачу по информатике 8 класс. Напишите программу для решения задачи. В соревнованиях по плаванию принимали участие N (значение задается с клавиатуры) спортсменов. Вывести время победителя, если известно, что заплыв продолжался 10 минут. В первой строке вводится N, затем результаты каждого учасника в секундах. Пример: 6 15, 5 16, 7 12, 3 18, 2 19, 1 16, 3 Результат: 12, 3

Информатика

Ответы

НосовЖелиховская

a, b = map(int, input("Введите два числа: \n").split())

a1,b1 = a,b

o = 0

while a1 != b1:

   if a1 > b1:

       a1 = a1 - b1

   else:

       b1 = b1 - a1  

   o += 1

a2,b2 = a,b

m = 0

while a2 != 0 and b2 != 0:

   if a2 > b2:

       a2 = a2 % b2

   else:

       b2 = b2 % a2  

   m += 1

print(f"НОД ({a},{b}) = {a1}")

print(f"Обычный: {o}")

print(f"Модифицированный: {m}")

Объяснение:

Вводим 2 числа (в строку через пробел)

Вычисляем НОД с обычного алгоритма Евклида и считаем количество шагов цикла

Вычисляем НОД с модифицированного алгоритма Евклида и считаем количество шагов цикла

Выводим результат

gurina50
Uses GraphABC; 
procedure Draw(x, y, l, u : Real; t : Integer);

procedure Draw2(Var x, y: Real; l, u : Real; t : Integer);
begin
Draw(x, y, l, u, t);
x := x + l*cos(u);
y := y - l*sin(u);end; 
begin
if t > 0 then
beginl := l/3;Draw2(x, y, l, u, t-1);Draw2(x, y, l, u+pi/3, t-1);
Draw2(x, y, l, u-pi/3, t-1);Draw2(x, y, l, u, t-1);end
else
Line(Round(x), Round(y), Round(x+cos(u)*l), Round(y-sin(u)*l))end;
begin
SetWindowSize(425,500);
SetWindowCaption('Фракталы: Снежинка Коха');
Draw(10, 354, 400, pi/3, 4);Draw(410, 354, 400, pi, 4);
Draw(210, 8, 400, -pi/3, 4);end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

решить задачу по информатике 8 класс. Напишите программу для решения задачи. В соревнованиях по плаванию принимали участие N (значение задается с клавиатуры) спортсменов. Вывести время победителя, если известно, что заплыв продолжался 10 минут. В первой строке вводится N, затем результаты каждого учасника в секундах. Пример: 6 15, 5 16, 7 12, 3 18, 2 19, 1 16, 3 Результат: 12, 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

manager9
Elshel8694
mixtabak2
NikolayGoncharov
blizzardtap641
BirUlek215
Lorvi_Shevkunova849
rodsher7740
andreokiseleo69421
denspiel
romolga3580
Кирьяков-Крикунов
secretary
olimov9
ПаничерскийЕлена