AHO436
?>

Составить программу нахождения произведения нечетных чисел от 1 до 100 (цикл с постусловием) Составить программу нахождения суммы четных от 2 до 100

Информатика

Ответы

bksenia9775

Т.к. требуется использовать цикл until, то значит требуется код на языке Паскаль.

1) цикл for

program p_for

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  p := 1;//начальное значение

  for i := 1 to n do  

     p := p * i;

  writeln(p);

end.  

2) цикл while

program p_while

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  while i <= n do  

  begin

     p := p * i;

     i := i + 1;

 end;

 writeln(p);

end.  

3) цикл until

program p_until

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  repeat

     p := p * i;

     i := i + 1;

  until i > n;

  writeln(p);

end.  

Объяснение:

ninazholnerova9

program yourname;
uses crt;
var com:string; i:integer;
begin
writeln('Задайте значените программы.');
writeln('Для того чтобы программа посчитала от 1 до 5 пропишите команду  "go1".');
writeln('Для того чтобы программа посчитала от 5 до 1 пропишите команду  "go2".');
writeln('Для того чтобы сказать программе - пропишите команду "go3".');
readln(com);
If (com = 'go1') then begin
writeln(Программа считает от 1 до 5');
for i:=1 to 5 do writeln(i) end
else if (com = 'go2') then begin
writeln('Программа считает от 5 до 1');
for i:=5 downto 1 do writeln(i) end
else if (com = 'go3') then begin
writeln('Программа: Всегда рада вам
else begin writeln('Данной команды не существует либо вы ввели команду вместе с ковычками.');
Перезапустите программу.') end

 

end.

dimari81

 список учительницы                                                              список Марины 

Катя Арбузова                                                                            Марина Яблочкина

Яша Арбузов

Коля Белкин                                                                              Роберт   Щукин

Лена Волкова                                                                             Сережа Тополев 

Дима Иволгин                                                                             Валя Стрелкина    

Валя Стрелкина                                                                         Дима Иволгин 

Серёжа Тополев                                                                         Коля Белкин                                                                                                                                                      Лена Волкова

Роберт Щукин                                                                              Яша Арбузов

Марина Яблочкина                                                                     Катя Арбузова

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу нахождения произведения нечетных чисел от 1 до 100 (цикл с постусловием) Составить программу нахождения суммы четных от 2 до 100
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sancity997124
Валиахметова
Kushchenko-Monashev
Andreeva
margo929
svetavancevich
Эрендженова
alexderru
vshumilov
sve707ta
ustinov434
hrim5736
ГармаеваЕкатерина1637
Татьяна1856
triumfmodern