pechatlogo4
?>

Определите значение переменной, которое будет выведено на экран после выполнения следующего фрагмента программы n:=10; sum:=0; for i:=1 to n do; if (i mod 2=0) then sum:=sum+i; write (sum); конечно мне сгодится и ответ, но хотелось бы посмотреть на решение

Информатика

Ответы

staskamolbio5152
CHKDSK (сокращение от check disk — проверь диск) — стандартное приложение в операционных системах DOS и Microsoft Windows, которое проверяет жёсткий диск или дискету на ошибки файловой системы (например, один и тот же сектор отмечен как принадлежащий двум разным файлам) . CHKDSK также может исправлять найденные ошибки файловой системы.

Под Windows NT, Windows 2000 и Windows XP, CHKDSK также может проверять поверхность жёсткого диска на наличие физически повреждённых секторов (bad sectors). Найденные сектора отмечаются как повреждённые, и система больше не пытается читать с этих секторов или писать на них. Ранее эту задачу выполнял SCANDISK.

В системе UNIX аналогичная команда называется fsck.

По умолчанию, CHKDSK не исправляет ошибки и не проверяет поверхность диска на наличие повреждённых секторов. Для исправления ошибок необходимо задать флаг /F. Для поиска повреждённых секторов (наряду с ошибками файловой системы) необходимо задать флаг /R.

Если использовать флаг /R или /F, CHKDSK требует монопольный доступ к диску на чтение. Поэтому если на диске есть открытые файлы (например, если это загрузочный диск) , CHKDSK не может начать работу немедленно. Вместо этого, он предлагает автоматически выполниться при следующем перезапуске ОС.

Выполнение CHKDSK занимает некоторое время (обычно минуты или десятки минут) . Для того, чтобы посмотреть результаты CHKDSK, выполненного при перезапуске ОС, необходимы следующие шаги:

Откройте Control Panel
Дважды щёлкните мышкой на Adminstrative Tools
Дважды щёлкните мышкой на Event Viewer
Щёлкните мышкой на Application в левой части окна
В колонке Source найдите слово Winlogon
Дважды щелкните мышкой на найденной строке
Чтобы запустить CHKDSK под Windows, можно или набрать команду из консоли, или выполнить следующие шаги:

Запустить приложение My Computer
Щёлкнуть правой клавишей мышки на нужный диск или дискету
Выбрать Properties
Выбрать закладку Tools
Нажать кнопку Check now
symkifm
Т.к. язык программирования не указан, сделаю на свой вкус, т.е. C++. При копировании кода из IDE на сайт автоматически удаляется перенос строки. Будет прикреплен скриншот того, как должен выглядеть код

#include <stdlib.h>#include <stdio.h>#include <locale.h>
void main(){ setlocale(LC_ALL, "RUSSIAN"); int a, b, c; printf("\n Введите первое число -->"); scanf_s("%d", &a); printf("\n Введите второе число -->"); scanf_s("%d", &b); printf("\n Введите третье число -->"); scanf_s("%d", &c); if ((a + b > 0) || (a + c > 0) || (b + c > 0))printf("\n Сумма каких-либо двух чисел является положительной"); else printf("\n Сумма любых двух чисел отрицательная"); printf("\n\n"); system("pause");}
Напишите программу , которая по заданным трём числам определяет , является ли сумма каких либо двух

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Определите значение переменной, которое будет выведено на экран после выполнения следующего фрагмента программы n:=10; sum:=0; for i:=1 to n do; if (i mod 2=0) then sum:=sum+i; write (sum); конечно мне сгодится и ответ, но хотелось бы посмотреть на решение
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Сергеевна-Пузанов
По то нужно умолч По то нужно умолч
Timurr007
saveskul84
sapelnikovk-74
Shitikov-M.A.1307
zorinka777
sabinina0578
alexkortyukov
Alekseevich_Viktorovna
shmanm26
Dmitrievna Lvovich
BrezhnevaKoidula
snopok66
Викторович
Чечин-Павлова615
▲