knyazev527
?>

2. Написать программу, которая будет складывать, вычитать, умножать или делить два числа. Числа и знак операции вводятся пользователем. После выполнения вычисления программа не должна завершаться, а должна запрашивать новые данные для вычислений. Завершение программы должно выполняться при вводе символа '0' в качестве знака операции. Если пользователь вводит неверный знак (не '0', '+', '-', '*', '/'), то программа должна сообщать ему об ошибке и снова запрашивать знак операции. Также сообщать пользователю о невозможности деления на ноль, если он ввел 0 в качестве делителя.На с++

Информатика

Ответы

forwandy42
1.
n = int(input("N="))
heads = n * 3 if n <= 100 else 100 * 3 + (n - 100) * 2
eyes = heads * 2
print(heads)
print(eyes)
2. Используется прямая формула для н-ого члена
for x in range(1, 9):
  print(int((1/(5**0.5))*1+5**0.5)/2)**x)-(((1-5**0.5)/2)**x
3.
try:
  num = int(input("N="))
except ValueError:
  print('Not a number')
if num > 2000000:
  print('too big')
else:
  print(len(str(num)))
5.
a = abs(int(input('a=')))
b = abs(int(input('b=')))
while a!=0 and b!=0:
    if a > b:
        a %= b
    else:
        b %= a
print(a + b)
peshnoshamon

Решение

Объяснение:

1. Создать 2 переменные, сделать проверку через if Если a>b то writeln(a+b) else writeln(a*b) После этого writeln("ЗАДАЧА РЕШЕНА")

2.Создать переменную n(Сколько лет дракону) и h(Голова) Так же сделать проверку через if сколько ему лет Если >100 то n*3 Если <100 То (100*3)+((n-100)*2) и записать в переменную h

Что бы получить глаза достаточно h*2 (если у дракона 2 глаза)

3.Создать 2 переменные, сделать проверку через if допустим если a<b writeln(a) else (b)

4.Создать переменную в которую пользователь будет вводить число,

После этого надо его делить на 4 и округлять в меньшую сторону

Если число будет 1 - Зима Если 2 - Весна 3 - Лето 4-Зима

5. -

6. Создаем 2 переменные a,b - Записываем в них длины сторон после умножаем a*b

7.Создаем переменную скорости и расстояния - Потом Расстояние делим на скорость 600/120 И получаем время в полете

8.-

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

2. Написать программу, которая будет складывать, вычитать, умножать или делить два числа. Числа и знак операции вводятся пользователем. После выполнения вычисления программа не должна завершаться, а должна запрашивать новые данные для вычислений. Завершение программы должно выполняться при вводе символа '0' в качестве знака операции. Если пользователь вводит неверный знак (не '0', '+', '-', '*', '/'), то программа должна сообщать ему об ошибке и снова запрашивать знак операции. Также сообщать пользователю о невозможности деления на ноль, если он ввел 0 в качестве делителя.На с++
Ваше имя (никнейм)*
Email*
Комментарий*